Can't upload Balena sound

I have tried to upload from different os, Ubuntu 16.04, 18.04 and Windows 10.

Hi, we are investigating the issue and will get back to you when we have news.

okay, thanks.

same Here

Hi @rolik2001 and @MikeB1974 welcome to the forums.

The error you guys have been getting looks to be because we had a requirement for the alsa-base package which is no longer present in the latest version of the base images. We have just released a new version of balenaSound with this removed so if you download the latest version and try pushing again you should be good to go! I hope this helps.

the same error with bluealsa

You can remove any other packages that are causing an error from bluetooth-audio\Dockerfile.template.

Could you post a screenshot of the error you’re getting with bluealsa, before you removed it from the Dockerfile?

Never mind, I re-imaged it to developer mode, and now its working, but it keeps Cutting out, could be pandora or my phone

Hi,

Adding to this thread since I’m having the same issue.
Error with bluealsa present in Dockerfile:

Image pulled today (2019-08-15)

@solsatra welcome to the forums and thanks for trying balenaSound!

Could you confirm what device type you have set in the dashboard? I have just built the app for Raspberry Pi 1/Zero and Raspberry Pi 3 and both worked successfully so I wonder if maybe you are trying to build for Raspberry Pi 3 (using 64 bit OS) which is unsupported and won’t work.

Hello,

While I am not the OP, I am running into the same issue. I have tried on both macOS and Linux (Manjaro).

Raspberry Pi 3 64 bit OS is unsupported, but how are we meant to deploy the correct OS if your site only provides this beta version?

See: https://imgur.com/4VzyddK

Thanks.

@Jamdoog welcome to the forums and thanks for trying the project.

You can’t (currently) mix 32 and 64bit Raspberry Pi devices within the same application, so the fact you’ve set the application default as 64bit Raspberry Pi means that this is the only one of the two devices that you can select on the add new device screen. If you create a new application using Raspberry Pi 3 as the default then you’ll be able to add one.

1 Like