Cant select target drive for clone on MacOS

I am trying to clone a 32G microSD for NVIDIA Jetson NX to a larger 128G microSD. The smaller one is in a USB adaptor and the larger directly in the SD slot of the Mac Pro. I see both drives in the source tab, but when I switch to the target tab all selections are gray and say source on far right.

Hi @gene,

I wasn’t able to reproduce this on the latest balenaEtcher 1.5.110.
When testing on a 16GB & a 32GB SD card (over USB card reader), I was able to select the small SD card as the source and the larger one as the target and get the “Flash!” button enabled.
I was only getting the “Source drive” label on SD card I selected in the first step, and was able to select the other one normally.

Can you clarify the balenaEtcher version and the OS that you are using?

Kind regards,

I tried first with 1.5.104 and then again with 1.5.109 (latest on web site as of an hour ago).

PastedGraphic-2.pdf (123 KB)

Hi @gene,

Are you running Etcher as admin or as a regular user? Also, are you by any chance running Chrome Remote Desktop on the Mac? It’s been known to play havoc with POSIX.


I have admin privileges, but have not been asked for credentials. I am not running any remote desktops.

PastedGraphic-2.pdf (123 KB)

Can you try running Etcher As Administrator (launching the app with elevated privileges)?


Having had flaky problems before, I did the standard and rebooted. Noticed that Cisco WebEx started in background and disabled. Same behavior.

PastedGraphic-2.pdf (123 KB)

Hey Gene, I just reproduced this on my MacOS on v1.5.109, so it looks like it might be a bug. We will continue to investigate.

Hi, just an update after talking to the etcher team, they confirm this was a bug and has been fixed in 1.5.110 and which they are working on preparing a release for. So hopefully this will be fixed in the coming days or week when the new release rolls out.

if you are interested in testing an early version of this, you can grab it here:


Your software has major issues.

When I try the beta 1.5.110 to flash from file on the mac, it complains that something went wrong and the compressed file is corrupt - which it is now.

I switched to a Win10 machine and released 1.5.109 and downloaded fresh zip file. Successfully flash the SD and install in Jetson - works. Perform all the OS updates on Jetson and setup environment then take the updated SD card back to the Win10 machine and try to clone to an identical SD card. As a precaution, I tried to write protect the source SD, but it would not let me select it as source claiming it was lock. Unlocked the source and can select source and target. The clone fails complaining the source SD is corrupt. Put the source SD back in the Jetson and it is blank.

PastedGraphic-2.pdf (123 KB)

Hello Gene,

the compressed file is corrupt - which it is now.

Etcher opens the source file read-only, it can’t alter it. See and

I tried to write protect the source SD, but it would not let me select it as source claiming it was lock.

This is a bug and I can reproduce that, we will fix it in the next release.

Put the source SD back in the Jetson and it is blank.

Etcher opens the source drive read-only, it can not alter it. See and

What kind of SD card are you using ? Do you have the Etcher logs of when this happened ? (Press CTRL + SHIFT + i then go to the Console tab).

Hi Gene,

Issues related to not being able to select a write-protected SD as a source drive in Etcher have been fixed in the latest version, 1.5.111.


Hi There,
I am on MacOS Monterey 12.1 (21C52)
I am experiencing a similar issue. I can launch the Etcher (1.7.3) . I can select the sd card as source for the image I need to clone. I cannot select the destination on the MAC. It shows me some partition on the Mac ssd (where it is not allowed to write) but does not show the path allowing me to select the destination. I have admin credentials on the Mac.
I did try the same using my wife’s Mac still running Big Sur and I succeeded in cloning the sd card.


Could you please clarify what are you trying to clone and your setup? Is it two SD cards (one plugged in to the mac SD card slot and one through an adaptor)?

What do you mean “cannot select the destination on the MAC”? If you’re trying to overwrite your MAC’s drive with the contents of the SD card, that wouldn’t be allowed.