Cant push basicstation

Similar to the post by eversteeg Unable to push basicstation - Product support - balenaForums

I tried following the tutorial things academy summer school on Youtube to set up my TTN gateway via baleana and add wifi-connect. I am using a Raspberry pi 3 and a RAK2245. I was able to connect to TTN but I am getting the same error as the post I referenced when trying to push the wifi-connect docker like how you demonstrated in this video, (135) The Things Summer Academy - Gateway Workshop - YouTube.
I get the following error:

Error: The command ‘/bin/sh -c make platform=rpi variant=std arch=armv7hf’ returned a non-zero code: 2

My output is listed below

[Success]       Successfully pulled cache images
[basicstation]  Step 1/11 : FROM balenalib/raspberrypi3-debian:buster-build as builder
[basicstation]   ---> 9f6d059e9bd0
[basicstation]  Step 2/11 : WORKDIR /usr/src/app
[basicstation]  Using cache
[basicstation]   ---> f3bda7951e9a
[basicstation]  Step 3/11 : COPY . .
[basicstation]   ---> 4929b51df707
[basicstation]  Step 4/11 : RUN make platform=rpi variant=std arch=armv7hf
[basicstation]   ---> Running in 6a69606ff499
[basicstation]  mkdir -p build-local/bin
[basicstation]  gcc -std=gnu11 -Isrc -DCFG_prog_crc32 src/crc32.c -o build-local/bin/crc32
[basicstation]  mkdir -p build-local/bin
[basicstation]  gcc -std=gnu11 -Isrc -DCFG_prog_genkwcrcs src/genkwcrcs.c -o build-local/bin/genkwcrcs
[basicstation]  build-local/bin/genkwcrcs $(cat src/kwlist.txt | sed -e '/^#/d;s/[ \t]\+#.*//') > build-local/temp-kwcrc.h
[basicstation]  mv build-local/temp-kwcrc.h src/kwcrc.h
[basicstation]  platform=rpi variant=std make -C deps/mbedtls
[basicstation]  make[1]: Entering directory '/usr/src/app/deps/mbedtls'
[basicstation]  platform=rpi variant=std ./
[basicstation]  /bin/sh: 1: ./ Permission denied
[basicstation]  make[1]: *** [makefile:55: platform-rpi] Error 126
[basicstation]  make[1]: Leaving directory '/usr/src/app/deps/mbedtls'
[basicstation]  make: *** [makefile:67: deps/mbedtls] Error 2
[basicstation]  Removing intermediate container 6a69606ff499
[basicstation]  The command '/bin/sh -c make platform=rpi variant=std arch=armv7hf' returned a non-zero code: 2
[Info]          Uploading images
[Success]       Successfully uploaded images
[Error]         Some services failed to build:
[Error]           Service: basicstation
[Error]             Error: The command '/bin/sh -c make platform=rpi variant=std arch=armv7hf' returned a non-zero code: 2
[Info]          Built on 0602a6e
[Error]         Not deploying release.
Remote build failed

In the original post, the user solved this issue by doing it on a Mac. I do not have a mac and I am using Windows with balena CLI like the original poster. Is there a workaround to push from a Windows machine?

Hello @currydem apologizes for writing you late but i was on holidays.

Did you fix your issues? Could you please try to deploy this repo on your fleet?