Cannot download x86 -dev image

I have an application in and I have already downloaded the -prod image. I am currently trying to download the -dev image for the same application and Chrome will not download more than 700MB ending in a “network error”. It appears to be streaming the file to my browser over HTTP. Chrome does not report a total size (of what should be ~2.5GB).

Which device type and version are you trying to download?

Your dashboard calls it the NUC but I have booted the prod image on a newer intel laptop and it installed.

It appears I can download the .zip just fine. Not sure what’s going on but maybe you should make .zip the default image download format?

I just tried with a test application of my own here and it works OK for both types. How large is your image when unzipped?

It unzips to 2,211 MB when downloaded with Edge and Chrome both.

That doesn’t seem particularly large. I’ll do some more tests and see if I can reproduce it.

It’s about right after unzip. The failed .img download sticks at 670MB-691MB. My friend is a web developer and says your service is not sending a Content-Length header, but that shouldn’t make a difference. Also, I tried testing on the 100Mb/s and 200Mb/s connections at work, along with my cellular based internet at home. All perform the same. Zip works great though.

I have also verified that the zipped image boots correctly after flashing to a USB drive. It is checking in with the dashboard and installing to hard drive now.


I verified I was able to download the image in all formats - do you have a stable internet connection?

Yes I have <10ms ping to one of your servers. I work at a fiber provider so
it’s pretty much the best connection in the city.

hmm, what browser and OS do you use?

I’m on Windows 10 x64. I cannot download in chrome or edge. I don’t think I
tried Firefox yet.

Thanks for the update, we are going to see if we can reproduce. Do you have any more info that may be useful?

Not at this time. It’s been a busy night and day for me at work.