Buring image on Mac OSX with yubikey attached cause problems with authentication

When flashing an SD card on OSX (multiple versions and failing with current MacOS Ventura) with a yubikey installed, when the system promps for “balenaEtcher needs privileged access in order to flash disks. Type your password to allow this.”, neither the system passord, the yubikey password or touching the yubikey will get past this prompt. In fact, after several attempts, the yubikey will get disabled and causes a convoluted process to reactivate it. The only way to get past this prompt, is to remove the yubikey and then the system password is accepted.

Etcher Version 1.7.9 (1.7.9)
OSX Version 13.0
System Mac M1 Mini
yubikey 5 NFC pluged into USB on Mac M1 Mini

The workaround is simple (rempve the yubikey), however, the application does not work as all (all that I have seen) other applications that accept the yubikey password.

Hi John,

I just tried to reproduce the issue on my computer and everything worked as expected. My setup is not identical but pretty similar:

  • MacBook Air M1,
  • MacOS Ventura,
  • Etcher 1.7.9 and
  • yubikey 5C

The expected password is your user’s password.
If it doesn’t work with password, it might come from how you have set up your Yubikey software (mine is mainly for 2FA on websites, I don’t use it at OS level).

Thanks for the reaction. Yes, I have my yubikey set to also provide system level security (eg, login pin)

Thanks @drjohnm61 for reporting this. We have created an issue for this, you can follow here for updates: Etcher priviledged access request fails when `yubikey` auth is used · Issue #3829 · balena-io/etcher · GitHub