Building yocto on coral install issues


I’ve been tinkering with BalenaOS & the coral dev board for a couple of days now and installing the prebuilt coral version via the sd card works fine. Also I can connect it to the balena cloud.

However I’m currently trying to build the balena repository for coral to create a custom yocto build with additional dependencies. Building seems to not be a big issue, but installing it to coral seems to be. For this demonstration I’ve left everything default (eg. didn’t add any changes of my own to create issues)

I followed the custom build steps described in the repo readme:

I uploaded screenshots of the errors imgur here

The build seems to finish fine with some warnings (first image in imgur)

After that I flashed the .balena-img to a microsd with balenaetcher. And tried to boot coral with that card. The errors are described in images 2&3 in imgur

After letting the installer run for a while it shuts down the board as with the prebuilt image flasher. However when attempting to boot the device fails to boot and gets stuck in the last image state.

Is this an issue with something I’m not setting during the build setup(eg in local.conf which is left default) or something else?

The very same coral dev board unit works with the prebuilt image, but not with the “custom” build.

Hi, welcome to the forums. Is the image you are building at the same version as the image you are downloading from the cloud?

To debug this on the current master, I would build an OS development image which you can do by passing the -d argument to barys. I would also add:


To your conf/local.conf so you can stop into the U-boot shell in case you need it.

The development image should provide a console login from where you can inspect the logs (journalctl).

The prebuilt version that I was using was 2.67.3-rev2, which was the latest available version from the cloud dashboard menu when adding a device.

For this test with git I checked out the release tag corresponding to version 2.98.33, so the prebuilt image is apparently much older.

With the -d option passed to barys I got a similar result, but could now login as a root after the system had been flashed to emmc by the flasher. I ran:

systemctl status resin-device-register.service

the service status was the following, and after a minute or so the system shut down on it’s own:

Is the system actually installing and running correctly, but just requires configuration or is this indicative of an actual issue?

Hi, the Coral Dev Board is a flasher device, which means that the image you download from the network boots from an external device, usually an SDcard, and programs a raw image into the internal storage. So initially you need to set the BOOT_SELECT switch to boot from SDcard. After this, the board shuts down. You are then expected to remove the external SDcard with the flasher image and let the device boot from internal storage by changing the BOOT_SELECT to boot from eMMC.
Once it boots from eMMC, the board is not supposed to shut down.
Could you please confirm you followed the process detailed above?