Flashing new Coral Dev Board 4GB


Following the flashing steps with a new 4GB Coral Dev Board, that should be similar to the original 1GB Dev Board, device never shuts down for the flashing process…


Any ideas?


Hello @rlomascolo

Welcome to our forums! Are you able to try the same SD card into another (1GB version ideally) board? Even trying a different SD card would help.

It would also be helpful if you could connect to the serial console and/or plug a screen so we can extract some more information.


Sadly the 1GB devboard I had is not at the office at the moment and will take some days to be back.
Tried another SD card , 16GB and same problem.
In SD boot mode: No screen output, serial output gets the output from U-boot as copied below

U-Boot SPL 2019.04.1 (Apr 29 2020 - 18:40:05 +0000)
Board id: 0
DDRINFO: start DRAM init
DDRINFO:ddrphy calibration done
DDRINFO: ddrmix config done
Normal Boot
Trying to boot from MMC1
hdr read sector 300, count=1
U-Boot 2019.04.1 (Apr 29 2020 - 18:40:05 +0000)
CPU: Freescale i.MX8MQ rev2.1 1500 MHz (running at 1000 MHz)
CPU: Commercial temperature grade (0C to 95C) at 32C
Reset cause: POR
Model: Freescale i.MX8MQ Phanbell
Loading Environment from MMC… *** Warning - bad CRC, using default environment
In: serial
Out: serial
Err: serial

  • ATF
  • U-Boot 2019.04.1
    flash target is MMC:0
    Warning: ethernet@30be0000 using MAC address from ROM
    eth0: ethernet@30be0000
    Fastboot: Normal
    Normal Boot
    Hit any key to stop autoboot: 0

Welcome to your new Coral EdgeTPU Development Board!

To get started, you need to download and flash the latest firmware.
Please follow the instructions at g.co/coral/setup.
Configured USB Switch for UFP
In fastboot mode. Press Control-C to exit.
In fastboot mode. Press Control-C to exit

Hi there, are you able to catch/post the log/screen output during the flashing process on the 4GB model?

Hi , the logs only come from serial connection, no screen output.
The messages are in a previous post up in this post.

OK thank you. I’ll raise this internally to see if we can replicate and advise in due course.

Hi @rlomascolo,

I don’t have the 4GB version to test, but from the logs you pasted it appears that u-boot is loaded from the eMMC and not from the BalenaOS sd-card. Can you please confirm if all the boot switches were in sd-card boot mode (all switches are in off position) when booting from the BalenaOS card? You can re-try moving the first switch to off, to rule out imperfect contact, and check if you still see “U-Boot 2019.04.1 (Apr 29 2020…”

Another way to check if the switches are in sd-card mode is to boot with no card is inserted, and no u-boot logs should be visible on the serial.

Problem solved changing switches but there is an inconsistency somewhere here.
I tried many times with the ON OFF ON ON configuration for booting from SD Card, but could not get it booting from the SD. (balena+coral docs and Google Coral docs)
According to your post i tried the OFF OFF OFF OFF and it worked… now my Coral is running balena without the SD

Many thanks !!

Glad that it worked for you.
Thanks for letting us know, I will pass this internally to investigate and double check whether we need to change our docs.

Kind regards,

Hi, I am just writing to inform you that we have updated our docs and the getting started guide now contains a note about the need to set all switches to OFF: Get started with Coral Dev Board and Node.js - Balena Documentation

Thanks, good to know


I have tried all of the above and still cannot get the flashed SD card to load image, no logs it just sits there, with terminal connected. I was able to flash the original image as per Coral get started guide. Their flash programs, as part of the options for flashing, has a handler for 16 GB image and 64GB. Is this a case that just doesn’t work with 32 GB image? Thinking outside the box, can the Balena image be reduced to something less than 32 GB, even if card has it available. Alt option, could the image be flashed without using SD card? There is provision for this in Coral advanced flash instructions for OEM image. But beyond me to alter the flash.sh.

Cont. Still no joy. I have tried with 32 GB and 64 GB SanDisk SD cards. I’ve tried with DIP switches in ONOFFONON and all OFF. Nothing. I have serial terminal running and nothing logged. Any ideas please?

I can flash the original software from 32 GB and 64 GB SD cards. From Balena image, it just doesn’t seem to kick start with any terminal output. I have tried from Mac and Windows machines. 4GB Coral Dev Board. Gave it 30+ minutes. But still nothing.

Try again with v2.56 rev 1 identified above (I used latest build from portal last time).
64GB card (brand new SanDisk) switches set as per Coral documentation - gets to bootloader message about Switch to BalenaOS environment. Then a couple of errors about partition. Then tries Fastboot: Normal. Then stays idle 15 mins no turn off as per below:

Switch to BalenaOS environment.

  • ATF d543fbb
  • U-Boot 2017.03.4-release-day+g8523a10
    SATA isn’t building
    Warning: ethernet@30be0000 using MAC address from ROM etho: ethernet030be0000
    can’t find partition: misc, dump the partition table cannot get the partion info for misc
    Cannot find partition 4080
    do_raw_read failed, ret 1 read _bootctl, beb_rw_block read failed read command failed
    Fastboot: Normal
    Hit any key to stop autoboot:

#2 switched all DIPs to off. Same.
#3 switched back to 32GB card (BNIB SanDisk) DIPs off. Same.
#4 switched back to 64GB card DIPS off. build 2.67 (earliest not outdated version in portal) Same.
Any thoughts welcome

Hello @gavin67890 just to confirm, which Coral Dev Board are you using? There are a few models (Dev Board, Dev Board Mini, Dev Board Micro) and also RAM (1 or 4 GB) and eMMC (8 or 16 GB)

Coral Dev Board 4GB (as per others in topic I’m hoping). 4GB goes with 16GB eMMC.

I went back to v2.48.0+rev5 and it installed successfully on 32GB SanDisk Extreme Pro SD card. However, I went to Settings > OS version in the console selected the latest version and it has failed, no log, no terminal. Any thoughts?

Update: Unfortunately, even minor rev switch from v2.48.0+rev5 to v2.56.0+rev1 failed (from terminal, device ended up back at U-Boot prompt.

Ok, I have now been through every line of the recovery options from Coral for the Coral Dev Board 4GB, and I’m fairly sure my board is fine. I’ve flashed everything I think there is to flash.

I have the default build loaded, can run demos, etc. However, I am still unable to load Balena after v2.48.0+rev5 via SD card or OTA. Open question to anyone who has Google Coral Dev Board 4GB, have you been able to flash from an SD v2.56 and later and or OTA? If yes, can you please provide exact details of SD card and or any tips.

Just to update:
I have tried various combinations, and I believe that for the Google Coral Dev Board 4GB that the last release that works successfully for flashing is v2.48.0+rev5.

I have tried the thread on the DIP switches, and I don’t think it makes any difference, so I would stick with the Coral defined positions.

I have tried different SD cards, 16GB and 32GB Sandisk Ultra and 2x 32GB and 1x 64GB Sandisk Extreme Pro. NB They all worked for the v2.48.0+rev5 and latest Coral Mendel releases.

I noticed that there is a ASUS Tinker Edge T (also i.MX 8 based), which will hopefully provide a bit of extra pull from the edge ML community.