BalenaSound: Spotify connect skips songs

Hi!

I follow the install guide for balena sound…

It was really easy to get the device up and running.
It also shows up as a speaker in spotify, however it skips the tracks when I try to play.
Additional info: I can play songs by connecting to the raspberry 3b as a bluetooth device.

Some code from the console:
[2022 WARN librespot_playback::player] Unable to load <SpotifyId { id: (idnumber), audio_type: Track }>
spotify Skipping to next track
spotify [2022-03- INFO librespot_playback::player] Loading with Spotify URI spotify:track:(number)
spotify [2022-03- ERROR librespot_core::channel] channel error: 2 1
spotify [2022-03- ERROR librespot_playback::player] Unable to load encrypted file: ChannelError
spotify [2022-03- WARN librespot_playback::player] Unable to load <SpotifyId { id: (idnumber), audio_type: Track }>
spotify Skipping to next track
spotify [2022 INFO librespot_playback::player] Loading with Spotify URI spotify:track:(number)
audio W: [pulseaudio] module-loopback.c: Cannot set requested source latency of 66.67 ms, adjusting to 68.54 ms
audio W: [pulseaudio] module-loopback.c: Cannot set requested source latency of 66.67 ms, adjusting to 68.54 ms
spotify [2022-03 ERROR librespot_core::channel] channel error: 2 1

Hey,

That’s really interesting - just to clarify a bit more when you say it skips tracks when you try to play, do you mean that it skips the first track and then continues to skip subsequent ones, or just that it skips the first track selected?

Can you also let me know what version of BalenaOS you’re running and I’ll have a go at replicating the issue.

It is an endless loop of skipping. Not just the first step.

BalenaOS 2.94.4 - supervisor version 12.11.36

Spotify 3e61549