BalenaSound RPi3 stopped playing audio after moving device.

A long while ago (maybe 6 months) I had sound and pihole services running on one device. For a technical reason that changed to a standalone pihole device. The issue I had with pihole is now resolved and so I would like to move back to a multi project device.

I created the release; a combination of pihole and sound in to one docker-compose.yaml file, along with various other edits, all of which was pushed to a new fleet on BalenaCloud.

I moved the pihole only device to the pihole and sound fleet and everything on screen looks good. Only problem is no sound using Spotify Connect. I have a small few environment variables set for device name, bluetooth name, and soundmode (standalone). I can’t think what is different now for this not to work.

Any ideas?

Should it be possible to run spotify connect with only the audio and spotify services?

Using speaker-test on the audio service produced an output, so audio is working of sort.

I should clarify my OP, Spotify player would connect and play just no sound produced.

I have moved Pi-Hole to a separate system so had the opportunity to install just BalenaSound. Unsurprisingly it just worked, so the problem is in my customisation somewhere. I don’t need to resolve this issue, considering it solved.