BalenaSound not Working on RaspberryPi 3A+

I am trying to use BalenaSound on the Rpi 3A+ but none of the images I have tried for the Rpi 3 will play audio or work (Reg/64bit OS/New images/Older images/Production/Development). I am trying to run audio through my audio interface via usb.

When I try the regular Rpi 3 images I get
exec /usr/local/bin/ exec format error

When I tried the 64bit OS Rpi 3 images I get multiroom-client errors.

 multiroom-client  2023-05-16 05-50-25.716 [Error] (Controller) Error: Connection refused
 multiroom-client  2023-05-16 05-50-25.717 [Error] (Connection) Error in socket shutdown: Socket not connected
 multiroom-client  2023-05-16 05-50-26.719 [Error] (Connection) Failed to connect to host '', error: Connection refused

Any help would be great.

Hi there, as a first step, maybe try disabling multi room - this can be done by setting the SOUND_MODE device variable to STANDALONE Customization | Balena Sound

1 Like

Thank you for your help and for taking the the time to write a response to this post. The cause of the issue was my 18i8 Focusrite audio interface (second gen). I purchased a scarlette solo from sweetwater and everything is now running smoothly on my RPI 3A+.

For anyone who ends up here while troubleshooting, the following links helped me.