BalenaSound blutooth not working RPi zero W

I found this project while trying to set up a wifi/bluetooth audio receiver to play pandora on my older hi fi setup… I had a Raspberry Pi Zero W with a HiFiBerry DAC+ Zero laying around so I gave it a shot.

Setting up the applicaion on Balena’s site was easy and straight forward, I built the application with the latest production version
flashing the SD Card was exactly as expected
The RPi booted as expected
The RPi was discovered on the control panel
I grabbed a copy of the latest project files from GitHub
Using the CLI I uploaded the project files to the application
watching the control panel Airplay, bluetooth audio, fleet supervisor, Snapcast client and spotify all pushed to the RPi and went to a running state. Snapcast server pushed but is in a stopped state.

To be safe I rebooted the RPi, I get a solid green light on the RPi, The RPi shows up in the control panel
I edited the RESIN_HOST_CONFIG_dtparam variable to set ”audio=off”
and added the variable BALENA_HOST_CONFIG_dtoverlay with a value of hifiberry-dac

now comes the issues…
The RPi doesn’t show up as an availalbe bluetooth device on my phone
looking in the control panel online and watching the logs there are a bunch of errors showing up

06.05.20 18:14:48 (-0500) Service exited ‘bluetooth-audio sha256:350078a03b581c47044f33202dc0b76d0803461546763f103041dc2e8f9b551a’
06.05.20 18:14:48 (-0500) snapcast-client 2020-05-06 23-14-48 [Error] (worker) Exception in Controller::worker(): connect: Connection refused
06.05.20 18:14:48 (-0500) snapcast-client 2020-05-06 23-14-48 [Error] (stop) Error in socket shutdown: Transport endpoint is not connected
06.05.20 18:15:10 (-0500) Restarting service ‘bluetooth-audio sha256:350078a03b581c47044f33202dc0b76d0803461546763f103041dc2e8f9b551a’
06.05.20 18:14:39 (-0500) bluetooth-audio /usr/bin/bluealsa-aplay: BlueALSA connection failed: No such file or directory
06.05.20 18:15:11 (-0500) bluetooth-audio Setting output volume to 75%
06.05.20 18:15:11 (-0500) bluetooth-audio Connection notify volume is 75%
06.05.20 18:15:13 (-0500) bluetooth-audio amixer: Unable to find simple control ‘Digital’,0
06.05.20 18:15:13 (-0500) bluetooth-audio
06.05.20 18:15:13 (-0500) bluetooth-audio Error org.freedesktop.DBus.Error.UnknownObject: Method “Set” with signature “ssv” on interface “org.freedesktop.DBus.Properties” doesn’t exist
06.05.20 18:15:13 (-0500) bluetooth-audio Restarting bluetooth service

I have rebuilt the application at least 6 times using a combination of the latest builds of the OS and the project files, both in prod and dev. I have tried 2.48, 2.46, and 2.32 OS versions and project file versions 2.2.1, 2.2.2, and 2.2.3 (master)… I have tried all 3 OS versions in Dev and Prod.

I am really hoping someone on here has some suggestions on getting this working.



i saw someone else post that Wifi was interfering with Bluetooth on their RPi… so I just rebuilt with latest OS and project files, configured with Ethernet only, booted with USB Ethernet adapter, and am seeing the same issues :frowning:


  • Have you used Bluetooth on this device before?
  • What’s the output of systemctl status bluetooth?
  • We had another user on the forum who had logs quite similar to yours and it turned out that their BT hardware was faulty - forum thread here