BalenaFin hangs when booting and `rpiboot` hangs too

Today I connected my Balena Fin to power, and it didn’t boot like before - it just hanged and the screen showed the BalenaOS logo. Before I disconnected it from power yesterday, it worked OK. I have no idea what happened - I updated the system a few times in the last time I used it, and it worked OK.

This lead me to try to download I wanted to flash my project’s image on the device, with an updated supervisor version, and I ran rpiboot before trying to run balena local flush, (see this issue), and I got this response:

RPIBOOT: build-date Jan  1 1980 version 20221215~105525
Waiting for BCM2835/6/7/2711...

The build date is set by Nix - my package manager to a deterministic value. After it prints it, rpiboot hangs for ever (tested for a few minutes at least). Any idea why this hangs? Also, while it hangs, lsusb doesn’t show the BCM is connected.

I’m really frustrated as my whole project seems totally unusable now, and it took me years to build it, and I have no idea how to fix it :(.

1 Like

OK, the problem was a bad USB cable. Apparently, rpiboot will write that message even if there is no device connected at all, which is a bit confusing.

1 Like

Thanks for confirming that the issue was related to a bad USB cable @doronbehar