Balena Still Working

I am pushing my changes as usual to Balena master, but I get Still Working…
Tried to start it a couple of times and also left it overnight with no change.

Is there a way to debug this or is it internal of Balena?. Seems to be operational today, but this is the first time it hangs like this for me.


Hola Santiago!

Thank you very much for reporting this. We will research on this to understand what happened.


I found the problem, I updated 2 dependencies in my stack and it’s been a while since I update master.

Found an Issue with WifiConnect
I used curl -s
This repo was moved.

  "message": "Moved Permanently",
  "url": "",
  "documentation_url": ""

I updated the url and this worked again.

The issue was the combination of all three problems mixed.
I feel a bit in the dark when there is no output like in this situation, maybe more insight into the pipeline could be a good thing.

It’s pushing the changes to balena but I get this output

error: error in sideband demultiplexer
   478c07f..ccc008d  master -> master
error: failed to push some refs to ''

Thanks again for the reply.

Pushed a couple of more times and the error went away.

Not sure what happened but It’s ok now.

Hip Hip Hooray


Thanks for checking back in here. We’re glad the issue went away. Let us know if it happens again and we can take an even closer look.