BalenaEtcher won't flash to sd crad

Hi there,

Etcher says that it can not flash my image onto my SD card, and tells me to check if the image is corrupt. I have now downloaded it multiple times, different versions as well, but I have not succeeded.

The most recent balenaEtcher and the most recent MacOS.

Error from console: EPERM: Operation not permitted, open “[…]”, code EPERM.

I have tried running as root using sudo in Terminal…

Any ideas?


Hello @jacobtilly, are you able to share more information on what image you are trying to flash? Did you manage to flash other images successfully with Etcher or is this the first one? Finally, if you have the chance, can you share any logs (You should be able to access the electron chrome inspector via Cmd+Option+I on mac ) as they might help shed some light on the issue

I have the same problem. Image is

Console error:
{“stack”:“Error: EPERM: operation not permitted, open ‘/Users/vlad/Downloads/hassos_rpi3-2.12.img’”,“message”:“EPERM: operation not permitted, open ‘/Users/vlad/Downloads/hassos_rpi3-2.12.img’”,“name”:“Error”,“code”:“EPERM”,“syscall”:“open”,“errno”:-1,“image”:“hassos_rpi3-2.12.img”}

I’m running etcher version is Version 1.5.50 (1.5.50) on macOS Catalina beta 1 (10.15).
I managed to flash the same image on macOS Mojave 10.14.5.

I solved the issue by moving the image to the “applications” folder, i.e. the same folder as BalenaEtcher. I don’t know why it worked, but it worked!


@jacobtilly that’s great that you found a workaround, we’re going to keep an eye on this issue. We’d be interested to know if this workaround solves the issue for you too, @vlad (p.s. welcome to the forums!)