Etcher won't flash image on Windows 10

Trying to flash an SD card here. Windows 10 Pro build 19041.
Balena Etcher 1.5.109. When I attempt to flash the latest rasbpi OS image it fails.
I’ve tried running both as a normal user and running as administrator.

In both cases I get this error message in the log:
,“error”:{“name”:“Error”,“message”:“EPERM: operation not permitted, write”,“stack”:“Error: EPERM: operation not permitted, write”,“code”:“EPERM”,“syscall”:“write”,“errno”:-4048}

I’m attempting to flash this image (2020-08-20) to an SD Card.

------ full log entry -------
Thu Oct 08 2020 20:26:52 GMT-0700 (Pacific Daylight Time) Flash error ({“image”:{“size”:1845493760,“name”:“raspios-2020-08-20.img”,“hasMBR”:true,“partitions”:[{“offset”:4194304,“size”:268435456,“type”:12,“index”:1},{“offset”:272629760,“size”:1572864000,“type”:131,“index”:2}],“extension”:“img”,“path”:“F:\down\raspios-2020-08-20.img”},“drives”:[{“size”:15836643328,“isVirtual”:false,“enumerator”:“USBSTOR”,“logicalBlockSize”:512,“raw”:"\\.\PhysicalDrive5",“error”:null,“isReadOnly”:false,“displayName”:"I:\, "}],“description”:“Generic- SD/MMC USB Device”,“isUAS”:false}],“driveCount”:1,“uuid”:“7e59e44d-fe58-4e48-8a1e-f3ccb289aabf”,“flashInstanceUuid”:“7e59e44d-fe58-4e48-8a1e-f3ccb289aabf”,“unmountOnSuccess”:true,“validateWriteOnSuccess”:true,“error”:{“name”:“Error”,“message”:“EPERM: operation not permitted, write”,“stack”:“Error: EPERM: operation not permitted, write”,“code”:“EPERM”,“syscall”:“write”,“errno”:-4048},“sample”:0.1,“applicationSessionUuid”:“aca7f0f5-77c5-49ed-9fe8-71ea993bf4bb”,“flashingWorkflowUuid”:“83e7be49-dac4-4f3d-b93b-78cd2ea40e09”})

I’ve successfully used Etcher in the past on this PC (although with older versoins of both Etcher and Win10).

Hi there, please try starting Etcher as an Administrator Windows user, otherwise it may not have enough permissions to query/write the SD card.

I assume you mean ‘Run as Administrator’? I have already tried that, with the same results


Can you clarify whether you are using the windows installer or the portable variant?
It would be useful to check whether a using a previous balenaEtcher version fixes the issue, in case this is a regression, or trying a different SD card to make sure there is no issue with that part either.

Kind regards,

I retried on a new SD card and it flashed successfully. I’m not sure why the first card could not be written. It was successfully written in the past and used on a Pi, and the card is still writable if writing to the either the FAT or ext partitions.

Hi Ben,

Sounds like the first card has reached the end of it’s useable life. Unfortunately they do wear out. There’s a great article on our blog about this here:

Glad you’re up and running.