Balena sound raspberry pi zero with hifiberry miniamp multi

Hello,
I have balena sound running on a raspberry pi 3 with a hifiberry pro dac and everything works fine.

I also have a a raspberry pi zero with hifiberry miniamp. Right after setup everything worked (spotify, airplay and multiroom synced with the raspberry pi 3).

But after restarting it (unplugging) it stopped working. After starting up it appears briefly as a device but I cant connect and then it disappears.

I am using ‘hifiberry-dac’ as ‘BALENA_HOST_CONFIG_dtoverlay’. (also tryed ‘hifiberry-dacplus’)

This is the log…

24.03.20 13:05:10 (+0300) snapcast-client 2020-03-24 10-05-10 [Info] Chunk: 6 7 6 0 500 119
24.03.20 13:05:11 (+0300) snapcast-client 2020-03-24 10-05-11 [Info] Chunk: 6 6 7 0 500 119
24.03.20 13:05:12 (+0300) snapcast-client 2020-03-24 10-05-12 [Info] Chunk: 4 5 6 0 500 119
24.03.20 13:05:12 (+0300) snapcast-client 2020-03-24 10-05-12 [Info] Failed to get chunk
24.03.20 13:05:17 (+0300) snapcast-client 2020-03-24 10-05-17 [Notice] No chunk received for 5000ms. Closing ALSA.

After waiting a bit the log showed this
24.03.20 13:27:02 (+0300) snapcast-client 2020-03-24 10-27-02 [Err] Exception in Controller::worker(): connect: Connection refused
24.03.20 13:27:02 (+0300) snapcast-client 2020-03-24 10-27-02 [Err] Error in socket shutdown: Transport endpoint is not connected
24.03.20 13:27:03 (+0300) snapcast-client 2020-03-24 10-27-03 [Err] Exception in Controller::worker(): connect: Connection refused
24.03.20 13:27:03 (+0300) snapcast-client 2020-03-24 10-27-03 [Err] Error in socket shutdown: Transport endpoint is not connected
24.03.20 13:27:08 (+0300) Service exited ‘snapcast-client sha256:0f63e5e076c79ea927ab287354e42a30820ed69c3545bf5293812efafe50c66c’
24.03.20 13:27:08 (+0300) Killed service ‘snapcast-client sha256:0f63e5e076c79ea927ab287354e42a30820ed69c3545bf5293812efafe50c66c’
24.03.20 13:27:09 (+0300) Killing service ‘airplay sha256:d8d4f56ec66bd96b2db6594be70c7c482feaf77cbb03eb4965f3993974c9aa96’
24.03.20 13:27:24 (+0300) Killed service ‘airplay sha256:d8d4f56ec66bd96b2db6594be70c7c482feaf77cbb03eb4965f3993974c9aa96’
24.03.20 13:27:24 (+0300) Service exited ‘airplay sha256:d8d4f56ec66bd96b2db6594be70c7c482feaf77cbb03eb4965f3993974c9aa96’
24.03.20 13:27:25 (+0300) Killing service ‘spotify sha256:53f8ab4f67e91cfc178a1ab9740b464b9debdc275dc9127fc3bc3a98c11641bd’
24.03.20 13:27:41 (+0300) Killed service ‘spotify sha256:53f8ab4f67e91cfc178a1ab9740b464b9debdc275dc9127fc3bc3a98c11641bd’
24.03.20 13:27:42 (+0300) Service exited ‘spotify sha256:53f8ab4f67e91cfc178a1ab9740b464b9debdc275dc9127fc3bc3a98c11641bd’
24.03.20 13:27:42 (+0300) Killing service ‘bluetooth-audio sha256:fe42f6267dcc3105c33264c749d63a59b1b3ce7445b0103af8e490e65f8ac31c’
24.03.20 13:27:47 (+0300) Killed service ‘bluetooth-audio sha256:fe42f6267dcc3105c33264c749d63a59b1b3ce7445b0103af8e490e65f8ac31c’
24.03.20 13:27:47 (+0300) Service exited ‘bluetooth-audio sha256:fe42f6267dcc3105c33264c749d63a59b1b3ce7445b0103af8e490e65f8ac31c’
24.03.20 13:27:47 (+0300) Killing service ‘fleet-supervisor sha256:0fb5f57843bd9a6dbdc1abfbcb3aa004ef0fadb311b0c14fb1cbc035e292d50c’
24.03.20 13:28:03 (+0300) Killed service ‘fleet-supervisor sha256:0fb5f57843bd9a6dbdc1abfbcb3aa004ef0fadb311b0c14fb1cbc035e292d50c’
24.03.20 13:28:03 (+0300) Service exited ‘fleet-supervisor sha256:0fb5f57843bd9a6dbdc1abfbcb3aa004ef0fadb311b0c14fb1cbc035e292d50c’
24.03.20 13:28:04 (+0300) Killing service ‘snapcast-server sha256:30d96560e310acae20cb5e9459a8a56dded35170117beb3da8aaa3b3cc49bcfe’
24.03.20 13:28:04 (+0300) Service is already stopped, removing container ‘snapcast-server sha256:30d96560e310acae20cb5e9459a8a56dded35170117beb3da8aaa3b3cc49bcfe’
24.03.20 13:28:04 (+0300) Killed service ‘snapcast-server sha256:30d96560e310acae20cb5e9459a8a56dded35170117beb3da8aaa3b3cc49bcfe’
24.03.20 13:28:04 (+0300) Rebooting

Thank you for your help!

We use snapcast to add multiroom support. Looks like you are indeed using that since you have two devices set up. Can you try one thing? Disable multiroom support by following these instructions and check if the device is working as expected.

Looking at the logs, I don’t think this is related to your DAC.

Hello, thanks for the quick response!
Yes that works. After disabling snapcast, spotify and airplay work.

Any idea what the issue with snapcast is? It seems very strange to me especially since it worked right after setting it up.

Hello,

Could you please try restarting both devices, wait for them to appear online in the dashboard and then connect to the pi3 and start streaming ?
If this does not solve the issue, there is an http server running on each device on port 3000 that shows which ip is considered to be the snapcast master. Check that your pi zero has the pi3 as master.

Hello,
I changed the wifi settings of my router - it was set to combine 5ghz and 2.4. I disabled 5 ghz.
It seems to work a little better - snapcast works sometimes.

I checked the http server on port 3000 when it didnt work and it shows the client servers ip, its own ip. Is there any way to manually set the IP?

Hi Franz,
Regarding your question about manually setting the master’s IP - this is actively being worked on and has an issue attached here https://github.com/balenalabs/balena-sound/issues/122 .
Otherwise the maintainer of the project believes your problems could be due to the PI Zero being a bit borderline regarding the performance. A way to test this would be to use a PI3 instead if you have one available.