Balena Sound: librespot has been failing to authenticate the last couple days

I haven’t changed my password or updated and none of my fleet (all on different accounts) can’t authenticate.

Anyone else having this issue?

13.09.20 11:29:39 (-0400) spotify [2020-09-13T15:29:39Z INFO librespot] librespot (raspotify v0.14.0) 3672214 (2020-01-30). Built on 2020-02-16. Build ID: 7pZDdYUK
13.09.20 11:29:39 (-0400) spotify [2020-09-13T15:29:39Z INFO librespot_core::session] Connecting to AP “guc3-accesspoint-b-lvqg.ap.spotify.com:4070
13.09.20 11:29:40 (-0400) spotify thread ‘main’ panicked at ‘Authentication failed with reason: BadCredentials’, core/src/connection/mod.rs:121:21
13.09.20 11:29:40 (-0400) spotify stack backtrace:

1 Like

A shot in the dark. . . . .

Have you tried “updating” (re-entering) the credentials on one of the systems to see if that “solves” the problem?

Once that’s established, we can begin the process of narrowing things down to a true solution.

Hi there. How do I do that? I have the credentials set as variables at the moment

1 Like

Try hard-coding them?

Can you point me in to the right direction on how to do that? (sorry I am green with Balena)

1 Like

I actually just deleted the variables via the dashboard and it works now! But I am not sure how to use a nano like editor for ssh on the dashboard or where the config is

1 Like

I’m scratching my head over that one too.

I’m probably as green as you, so we will have to wait for wiser heads than ours to tell us what this means.

Sorry I can’t help any further, but I am also interested in how this works out

hey there @gluckmyn

Just some clarifications which will help better understand the problem:

  1. You mean your setup was working fine, will all the devices in your fleet and it suddenly stopped with the Authentication error?

I actually just deleted the variables via the dashboard and it works now!

Does this mean it is working without any credentials? Or you deleted them then added again?

Thanks

1 Like

Hi Rahul,

Initially I set the credentials for Spotify connect as a fleet wide variable (to test the device once I provisioned it) then I would override the variables on the device via the same dashboard variable section.

I started having the app just crash and restart giving the error of the bad credentials (this wasn’t happening before; new issue in the last week). Now I have deleted the fleet and device variables and it works (log in successful) so I assume it’s reading the previously stored value on a config file on the device.

Let me know if I can provide any more details.

Thanks

A

1 Like

Hi,

For now, you can delete the SPOTIFY_LOGIN and SPOTIFY_PASSWORD env vars and use spotify on the local network to play, if you need to operate Spotify via internet then please wait until the Spotify Authentication issue is fixed (we will let you know when it’s resolved).

Please let us know if you need further support on anything.

Kind regards,
Trong