Adding a layer to balena-beaglebone

I am building my own image of Balena OS and plan to include custom dtbo etc. I cloned the balena-beaglebone repository (since i’m running on a bb), now I understand I need to add my own layer, but what is the best practice to do this so it is maintainable?
Just creating a layer in my local repository doesn’t sound right as it will overwritten next time I pull from GIT.

Hi, local changes won’t be overwritten when you pull. If you create a fork you can even have your changes committed and merge from time to time from upstream.
Apart from dtbs, what other changes do you plan on doing?

Ok so I can include them directly in my fork of meta-balena-beaglebone

Mainly dtbs but I also have a USB model which is not in the list of supported modems so I might need some customisation there. As the rest will be set in the docker containers

Let us know if you are successful with that USB modem…If it’s a common enough model, perhaps we could Merge your work to support that particular unit, so other folks could benefit from it as well. :slight_smile:

Will do but currently stuck in building version 2.48 as I get the below errors

ERROR: balena-18.09.10-dev+git7cb464a406748016f2df0c31a9851d20456a3d31-r0 do_fetch: Fetcher failure: Unable to find revision 7cb464a406748016f2df0c31a9851d20456a3d31 in branch master even from upstream
ERROR: balena-18.09.10-dev+git7cb464a406748016f2df0c31a9851d20456a3d31-r0 do_fetch: Fetcher failure for URL: 'git://;branch=master;destsuffix=git/src/import'. Unable to fetch URL from any source.
ERROR: balena-18.09.10-dev+git7cb464a406748016f2df0c31a9851d20456a3d31-r0 do_fetch: Function failed: base_do_fetch

I’ve found this forum post which points to a PR change in the urls of meta-balena-common. Even though I’ve changed the file to match the one in the PR, I still get the same error.

The reason I am trying to build from version 2.48 is that I am using openBalena so I cannot pull the latest version as it is not supported.

Managed to fix the error by changing the BALENA_BRANCH variable from “master” to “18.09-balena”

Hi. So you fixed the wifi problem too?