Add New Device for CM4 IO Board Empty

Hi,

When trying to download Balena OS for Raspberry Pi CM4 IO board in the devices page, the “Select version” field is empty. If the default platform for the application is already the CM4 IO board, the form doesn’t show up at all. Is the CM4 IO board supported?

Thanks,

Andrew

Hi

  • The CM4 IO board is indeed supported, and you can find the list of supported devices here - Single-board computers - Balena Documentation
  • The Select Version should show you just v2.71.3 as a single version. If you can’t see this, can you please share a screenshot of what you are seeing. There’s perhaps a bug on the dashboard.

Must have been a bug on the dashboard, working now. Thanks.

@anujdeshpande Thanks for adding CM4IO, however it seems that there is no docker image for it ? Is that right ? balenalib/raspberrypicm4-ioboard-node for example does not exist in docker hub…
Should we do anything to make them available ? Please let me know, thanks

Hi @mrrobot

I had good success with balenalib/raspberrypi4-64 (specifically balenalib/raspberrypi4-64-python:3-build). The 64bit variant didn’t have the raspberry pi binaries (like raspivid, raspistill, etc) so I added them

# get raspberry pi stuff
RUN curl http://ports.ubuntu.com/pool/universe/r/raspberrypi-userland/libraspberrypi-  bin_0~20200520+git2fe4ca3-0ubuntu3~20.04_arm64.deb -o libraspberrypi-bin.deb && \
    curl http://ports.ubuntu.com/pool/universe/r/raspberrypi-userland/libraspberrypi0_0~20200520+git2fe4ca3-0ubuntu3~20.04_arm64.deb -o libraspberrypi0.deb
RUN install_packages ./libraspberrypi-bin.deb ./libraspberrypi0.deb

I also like to have raspi-gpio available for debugging, so I installed it

# download and install raspi-gpio
RUN git clone --depth 1 https://github.com/RPi-Distro/raspi-gpio.git && cd raspi-gpio && ./configure && make && make install && cd ../ && rm -R raspi-gpio

Hope this helps.

Andrew

@smithandrewc Thanks a lot for this quick reply. I’ll try to replicate it.
Have you been able to make the DSI port works for the 7inch touch display too?

@mrrobot, I guess I haven’t tried it yet but I can. I’ve got some boards with a DSI connection on them. I’ll give it a quick spin and let you know.

@mrrobot I can confirm that DSI1 (I would expect 0 works as well but I haven’t tried) works with the 7" touch display. To get it going you need add an appropriate dt-blob.bin to the /dev/mmcblk0p1 partition. If you’re unfamiliar with that, check out the Raspberry Pi page.. If you have trouble, let me know and I can post a working dt-blob.bin for you.

@smithandrewc That’s great, thanks a lot! Do you know anyway of adding the dt-blob.bin directly when flashing (on the SD card) ?
All good, just need to add the file at the partition root.

Hey @mrrobot @smithandrewc, I’ve opened a new GH issue to track the missing base images for raspberrypicm4-ioboard.

Thanks for bringing this to our attention!