Balena CM4 IO Board image: usb support

Hi there,

I flashed a cm4 io board image to my raspberry pi compute module 4 and found that usb devices are not being powered or detected (whereas things are working fine on Raspbian OS). Is anyone else seeing this? I also tried to edit the usb power setting in config.txt to no avail.

Thanks in advance

I have a Oratek Tofu board and I believe it works similar to the Pi IO board in that I needed to power the board with the barrel jack with a 12v power adapter in order for the USB hub to pick up USB devices. It did not work if powering through the USB-C port.

It may the same for you - have you tried powering the board through the barrel jack?

Hi barryjump, the CM4 IO Board doesn’t have a USB-C port, so I’d been powering it via the barrel jack. Currently using a 12V @ 4A adapter, but interestingly, when I swap Raspbian OS onto the CM4, the USB ports are working fine, which lead me to believe that something was wrong/unsupported in the balena-cloud-raspberrypicm4-ioboard-2.71.3+rev5-dev-v12.3.5 image I’m using.

I’m using the same image as you HOST OS VERSION: balenaOS 2.71.3+rev5 and it can see my USB devices (again its a Tofu not an IO board, but maybe it doesn’t matter?)

root@5254c10:~# lsusb
Bus 001 Device 003: ID 1199:a001  
Bus 001 Device 002: ID 0424:2514  
Bus 001 Device 001: ID 1d6b:0002

Hi barryjump,

Thanks, I eventually figured out that the problem was that rpi4’s usb is disabled by default to save power, as described in the datasheet, section 2.4. After adding dtoverlay=dwc2,dr_mode=host to config.txt, usb devices are showing/working. Thanks again