balenaOS on Raspberry Pi 400?

I know it’s not exactly an IoT device, but my use case includes trying it out and thus far, I can’t get balena OS Pi 4 64-bit 2.60.1rev5 to boot it. A couple other images like various Raspians and RISC also won’t boot it, though I have proven it can boot something.

Anyone have any tips? Nothing at boot, though my HDMI does detect that it’s up. Just a black screen.

Hi, we have to put our hands on a rpi400 yet (some of us already ordered it, some of us have it but didn’t get the time to answer yet).
We’ll get back as soon as we have more info, in the meantime I have some questions to start narrowing down the issue:

  • does it show at all on the dashboard?
  • what is that something that boots?
  • is there any way that you could grab some logs from the device? Could you connect to it from an external ssh session for example?

Thanks for the reply. I can get a few other OS’s to boot, like Raspian and piCore. The serial console reports:

switch to partitions #0, OK
mmc0 is current device
** No partition table - mmc 0 **
Card did not respond to voltage select!

So I think this is more an issue of the Pi 400 being finicky about the SD card burn process. I’ve tried a number of different ways (Etcher, dd, Raspberry Pi Imager) with no luck. For now, I think this is the Pi 400’s fault.

On second thought, maybe this is in Balena’s realm. I don’t know enough about the boot process to know if U-Boot is part of what the Balena image puts on the card or not, but at start, I get:

U-Boo 2020.07 (Oct 21 2020 - 11:03:27 +0000)

DRAM:  3.9 GiB
RPI: Board rev 0x13 outside known range
RPI Unknown model (0xc03130)
MMC:   mmcnr@7e300000: 1, emmc2@7e340000: 0
Loading Environment from FAT... ** No partition table - mmc 0 **

Hi Justin,

Following up on what my colleagues have added here, a few of our engineers have received their RPi400s and are seeing similar issues. One reports a continuous crash loop, which suggests issues with the boot loader or partition visibility. Same results using different types of SD cards (to rule out media failure) and flashing with Etcher and Pi imager. We’ll continue to investigate.


hey @incanus

A couple other images like various Raspians and RISC also won’t boot it, though I have proven it can boot something.

Can you confirm that you have been able to successfully boot a full operating system on your pi400? i’m trying to rule out that there is nothing wrong with your hardware itself as we have a colleague who managed to boot into other OSes like Ubuntu 20


Yes, I have booted Ubuntu Server, Ubuntu Core, RetroPie, and others.

Anyone had any success with the Pi 400 & balenaOS yet?

@incanus there’s some work being done on this over on GitHub

And also here

I believe we are just waiting to receive devices to further this.

Great, thank you. I will investigate and see if I can help test for some early feedback.

@incanus a PR got merged yesterday…

You would have to build the kernel yourself at this point, and I am not sure if you would be comfortable with doing that, but just thought I would keep you in the loop.

Hi @incanus, the Pi400 is now available for testing in the staging dashboard at Let us know how it works for you.

1 Like

@acostach working well for me!

1 Like

@incanus you should now be able to get the Raspberry Pi 400 in the main dashboard at

I just tested deploying Screenly OSE to it and it has worked nicely!

Thanks for the work here! I did try compiling my own kernel but got bogged down a bit and ran out of time.

FWIW, today I received my CM4 dev kit and was trying that first, which only had a black screen on the default Pi 4 balenaOS dev image. However, I tried this new Pi 400 image (on a hunch that the new Ethernet and other devices are similar) and that image worked on a CM4! So I’m sure it will also work fine on a Pi 400, but I will report back when I try that one.

1 Like

Also FWIW, using the Pi 400 image on the CM4 makes it show up in the dashboard as a Pi 400 (not too surprisingly) so that will need some attention as well.

Screen Shot 2020-12-20 at 9.30.33 PM


Thanks for the info with regard to the CM4. That’s very useful. As you say the CM4 and Pi400 share a very similar design which explains it :slight_smile:

I’ve created a github issue for it…

As expected, the new image works great on the Pi 400. Thank you!

1 Like

@incanus awesome glad it’s all working for you.

I’m sure the OS team will be happy to know that :slight_smile:

Have a great new year and let us know what project you are working on with Pi400 and balena!

Ciao @incanus did you have to adjust anything to get the Pi400 image to work on a CM4? Did you use wifi or ethernet for the connection?