Wifi-connect command --portal-passphrase not work

Hi, i stall direcly on raspbian lite correctly. I’ve problem with this command (not work -p, and not connect to AP after insert correct password ):
sudo wifi-connect -a 600 -i wlan0 -s balenaDash -p balenaDash

When insert password not connect to AP.

  • This command Work correctly without set a password (i connect successfully to AP):
    sudo wifi-connect -a 600 -i wlan0 -s balenaDash

This is my distro:
Linux raspberrypi 4.19.75-v7+ #1270 SMP Tue Sep 24 18:45:11 BST 2019 armv7l GNU/Linux

Successfull install all component

Checking this one


I will pass your question to our wifi-connect maintainer. In the meantime, you can also specific password via environment variable, can you please try to set PORTAL_PASSPHRASE and see if it works?

More details can be found here https://github.com/balena-io/wifi-connect/blob/master/docs/command-line-arguments.md

On raspbian lite, I set variable PORTAL_SSID in system.
With echo $PORTAL_SSID i see the variable value, but when i run the base command, the default value “wifi connect” not change.

Thanks for reporting those two issues. Last time those were working all well. I will check to see whether something has changed in the latest Raspbian Lite release and let you know.


Thanks so much. Can you add a guide if it works? example of command setting, end set variable in system ?

Hi, I did not experience any issues. This is what I did:

  1. Flashed an SD card with latest Raspbian Lite (September 2019)
  2. Powered it up and connected to it with ssh
  3. Run the WiFi Connect installer - bash <(curl -L https://github.com/balena-io/wifi-connect/raw/master/scripts/raspbian-install.sh)
  4. Launched WiFi Connect with the command you provided: sudo wifi-connect -a 600 -i wlan0 -s balenaDash -p balenaDash

I am able to successfully connect to the balenaDash access point and use WiFi connect to establish a connection to my router.

I used a RPi 3 B+ device. What happens when you repeat the exact same steps? Also what is the RPi model you are testing this on?


I use the same steps, but i update and upgrade all. The RPI version is the same, but i’ve run the follow command with sudo:

bash <(curl -L https://github.com/balena-io/wifi-connect/raw/master/scripts/raspbian-install.sh)

I run with sudo because the installation of networkmanager and the disable service dhcpd not work without sudo.

I retry the installation and upgrade you

Thanks in advance

There is not need to run it with sudo as the install script itself does that for all necessary commands. The pi user is in the sudoers list.

If you are using a different user, then you may run it with sudo. That should not make a difference anyway.