When opening fleets, Stuck at "Loading Fleet" page.

Tried to clean the cache, cookies and even tried to use another browser.

Hi Salman,

Is this issue still ongoing? Could you open the console and see if there are any errors reported?

Hi @jakogut, Thanks for get back to me.

Now, sometimes only I’m getting the error, next time I’ll check the console and share it here. Thanks.

@jakogut Here is the log!

ping @jakogut

Hey are you still having this issue ? I’m sure it’s been resolved given that this thread is a month old. Let us know.

Nowadays, I face this issue less frequently. I’ll keep you posted.

Hi, could you potentially be using an extension, or have some firewall settings that could be blocking the connection?

Hi, Yes I’m using a few extensions. But when I face the issue, I tried different browsers to see it’s related to the browser but at the time I got the same error in the different browsers too.


Have you tried opening an incognito mode window? Also, do you use Pi-hole or another similar setup?


  1. Yes, tried. but no difference.
  2. No.

This is very bizarre as it seems to work in every setup we have tried so far. Do you have access to VPN? Perhaps try it over a connection from a different country?

When this issue reappears could you check the following commands in a terminal?

nslookup api.balena-cloud.com
# should return a few IP addresses
curl -v https://api.balena-cloud.com/ping

No, I don’t use any VPN.

Sure @Hades32 .

C:\Users\Faris>nslookup api.balena-cloud.com
Server:  dns.google

Non-authoritative answer:
Name:    api.balena-cloud.com.domain.name