Updating Balena-PiHole

The only Ad Blocker that WAS running was pi-hole, and I’ve removed it from the network chain.

Hi, can you confirm you uploaded the public ssh key to the dashboard?
And also, can you confirm you have the private ssh key loaded in the terminal you are ssh’ing from? You can check that by running ssh-add -l

Here’s a screenshot of the dashboard:

I don’t know what ssh-add -l does, but when I do, I get

The agent has no identities.

I don’t understand this ‘feature’ of ssh. I have a half dozen computers on my network, and I get to them via ssh (with keys exchanged so that I don’t need a password). The central computer is the Mac on which I’m typing this message. It has a private ssh key. Then I guess I don’t understand “loaded in the terminal,” as it’s different from what I do with all the other computers I have.

Can you try ssh-add <path to the private key>, verify with ssh-add -l that it was added successfully and then try to ssh again?

I did that. Here’s the output from ping and my ssh attempt. I note that I am not running my Mac as root, and user ID mismatch usually requires a password.

[Tardis]~/% ping
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=64 time=2.554 ms
64 bytes from icmp_seq=1 ttl=64 time=1.661 ms
64 bytes from icmp_seq=2 ttl=64 time=2.554 ms
64 bytes from icmp_seq=3 ttl=64 time=1.970 ms
64 bytes from icmp_seq=4 ttl=64 time=1.772 ms
64 bytes from icmp_seq=5 ttl=64 time=2.003 ms
64 bytes from icmp_seq=6 ttl=64 time=1.908 ms
— ping statistics —
7 packets transmitted, 7 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 1.661/2.060/2.554/0.331 ms
[Tardis]~/% balena ssh
root@’s password:

Can you run balena ssh <uuid>? You get the uuid from the dashboard?

This is what I get:

[Tardis]~/% balena ssh a063ac919290bef7bc136a18669d94de
You have to log in to continue
Run the following command to go through the login wizard:
$ balena login
Additional information may be available by setting a DEBUG=1 environment
variable: “set DEBUG=1” on a Windows command prompt, or “export DEBUG=1”
on Linux or macOS.
If you need help, don’t hesitate in contacting our support forums at
For bug reports or feature requests, have a look at the GitHub issues or
create a new one at: https://github.com/balena-io/balena-cli/issues/

I just realized that my initial intent was to upgrade pi-hole, but now I have a problem with balena OS. This was the situation I hoped to avoid, as I cannot go back to something that works.

Can you try to login? Run balena login first and then try to ssh with the uuid again

That worked. I’m now logged in.

If I type curl

I get

curl: (7) Failed to connect to port 80: Connection refused

To clarify, after logging in you can successfully SSH to your device. Now you are continuing to debug why you cannot seem to connect to PiHole. Have you confirmed the configuration is correct as per what’s been outlined here: https://github.com/klutchell/balena-pihole#device-variables?

To members of the balena team: I appreciate very much your efforts to help, but I’ve decided to bail out. I own a Mac plus 8 other Linux-based computers in my house, so I decided to clone one of my other Raspberry Pi SD cards with Raspbian Stretch on it, then downloaded and installed PiHole from GitHub on the designated machine. As far as I can tell, it is running without any trouble.

I can see the merit of a docker-based framework if you have to deploy a software package to hundreds - or even five - machines. But for one package on one machine - the balena interface is very nice, but if something doesn’t work I found it equivalent to learning another OS-like layer just to get inside a machine that I own, let alone debug a framework that I know little about. It was too much learning overhead for me, given the likely return on time invested.

Again - thank you for your help, even if I’m not the target audience.

Hello, thank you for your feedback and thoughtful response. Glad to hear you got this working for you, feel free to come back to this anytime you decide to give Balena another go :slight_smile: