Unable to Create Device Service Variables

The add variable button is greyed out on the Service Variables page and displays this message.

If it helps at all I am following this tutorial on configuring Pi-hole. I’ve been successful all the way up to step 4. I added the TZ environment variable but after that I ran into this issue. Any help would be greatly appreciated! Also the button is also greyed out at the “fleet” level config page.

Hey @zigmo, welcome to the forums!

This is likely to be because there is no release pushed to the application (and by extension no service to attach the variable to).

Can you ensure that you first push the application and then assign them? We will probably restructure that tutorial a little to avoid this situation in the future.

To push the code, follow the step i the tutorial named “Deploying the software”.

Please let me know if this doesn’t work!

Just to confirm; the tutorial has now been updated to take this into account, thanks for your feedback, @zigmo!

@chrisys & @CameronDiver

Thank you so much for the responses!

I will be going to my schools hackerspace to retry the project in a couple of hours. I will let you know if I am successful or not. Really looking forward to getting this project up and running. :smile:


It worked!

Once again thank you so much for the response. :smile:

We’re happy to help! Enjoy!