Can't add service variables?

On older applications marked “Classic” I can create service variables, however on newly created “Starter” applications the “Add variable” button is disabled. Anything I need to do so that I can add variables to “Starter” apps?

Can you confirm whether you have pushed any release to your new starter application? The service list needs some code deployed so that it can extract that available service names, while in classic applications, which are not capable for multicontainer deployments, there is always a single “main” service.

We definitely need a better way to communicate that back to the user somehow and I opened an internal ticket for this.

We are also planning to release soon fleed-wide & device-specific env vars that are not related to services at all, I hope that you will find that useful for new apps.

Ah… I see what you mean. Yes, the device in the “Starter” application is still “Factory build”.

Looking at the server vs env var release now. I think I’m still not clear on the difference. Is there a good doc that elaborates on the difference between the two?

Here’s my (likely incorrect) understanding right now:

  • An environment variable is application specific override-able per device
  • A service variable is fleet-wide (regardless of application) override-able per device

About right, or am I off the mark?


Sounds about right, from what I have in my memory, but have you read our docs on Service variables and Configuration variables? I think those should clarify the differences quite well (and if they don’t – let us know!).

Ahh… is what I was looking for. Thanks.

I guess I’m still not clear on services or how to define them. Right now for a classic app I see that I have “main” and “service1”. Where can I add/modify services?

Have a read through – that should get you started on how to add / modify the services run on your device

I am having a similar issue, is there any chance you could take a peek at my post