Turning On Fan Jetson Tx2

Hi everyone!
I have successfully running a Resin Image on my Jetson Tx2. I want to run it in max power mode. I tried the following using raw Ubuntu on the Jetson and it worked, but when I tried that within Resin it failed.

To change the mode I executed

nvpmodel -m 2

And to turn on the fan I executed this script that was part of the Jetpack configs files.

In resin I got

./jetson_cores.sh: line 208: /sys/kernel/debug/tegra_cpufreq/M_CLUSTER/cc3/enable: No such file or directory
./jetson_cores.sh: line 209: /sys/kernel/debug/tegra_cpufreq/B_CLUSTER/cc3/enable: No such file or directory
./jetson_cores.sh: line 301: /sys/kernel/debug/bpmp/debug/clk/emc/rate: No such file or directory
./jetson_cores.sh: line 307: /sys/kernel/debug/bpmp/debug/clk/emc/mrq_rate_locked: No such file or directory
Can't access Fan!

How can I then have access to those low level features within Resin?

Thanks in advance!

Hi there,
This happens because /sys and /sys/kernel/debug are meant to have different filesystems. The solution here is simple. All you need to do is to mount a debug filesystem on /sys/kernel/debug which will expose the kernel debug paths.

The command you are looking for is:
mount -t debugfs none /sys/kernel/debug

Best regards,

Thanks! That resolved the issue!