Trying to Flash Home assistant but it gets stuck at 47%.

First of all thank you for responding.
I am trying to install Home Assistant using balena Etcher. I have succesfully managed to install balena however when i try to flash my device it just gets stuck at 47%.
I have checked the developer tool and i dont have any errors.
I have tried flashing the device using balenaetcher_v1.5.120 and balenaEtcher-Setup-1.7.8. I am not sure what i am doing wrong. Can someone please help.

Hi welcome to the balena forums, I am trying to understand the issue but I guess I’ll need more details to help you efficiently . Are you trying to flash the official home-assistant image on SD card or are you trying to flash balenaOS ? What platform are you using (Windows, Mac, Linux) and where did you get this image from? What SD card/drive are you using. If flashing balenaOS have you used Flash with Etcher from balena Dashboard or something else? Have you tried using the latest etcher version i.e v1.7.8? You can download it from here.
These details will help us track the root cause and help you better, thank you!

Hey @SamYang did you solve your issue? Let us know if you could check what my colleague suggested.