The writer process ended unexpectedly, help me

Greetings to you all,

Yesterday, I wanted to install an OS on my usb key and several times the software gave me the following message : The writer process ended unexpectedly. Please try again, and contact the Etcher team if the problem persists.
That’s it, and I went to forums and people were saying “you have to install version 1.2.1/1.3.1”, etc. So that’s what I did and nothing works, all that changes is the error message.
If I can give you one more thing to help me, my usb key went to fat32
I’m completely lost if someone could help me please I’ll be constantly on the forum to see if there’s been any answer to all this.

Thanks in advance,

There is another thread where a solution was to turn off Windows Defender Ransomware protection. That worked for me.

Link: The writer process ended unexpectedly.

Hey @Kori welcome to the balena forums! Thanks for chiming in @edramski.

Kori, in general we advise to use the latest version available as that would include all the previous bug fixes and more. Next, have you tried the solution outlined in the thread edramski linked?

Let us know if you are still having issues. Cheers…