Setting fleet's target release not possible during build

since the balenaCloud dashboard was updated recently, it’s not possible to change the application ^h^h^h :wink: fleet’s target release while a build is running.
The build indicator removes the drop down box to set the target release.

This causes an issue if one forgets to pin the fleets release to the current one and don’t update all at once because one wants to try out the new release on a dedicated, monitored device.
In earlier releases the drop down box for the application was always present.

Could you please re-add the drop down box for selection of the target release to be shown all the time?

Hello @fritz thanks for your feedback! I will send this to the balena UI team!

having said that, i tested myself, and maybe you can do it from the same Summary page from your Fleet, select the devices you would like to pin to specific release, click Actions button on the top right of the list, and then click Pin to release.

Let me know if that workaround works for you. Let me attach a picture below

Hi @mpous,
yes, this workaround is clear! Thanks.
Anyway, thanks for forwarding it to the UI team!

1 Like

Glad that this worked @fritz

Thanks for raising this. This indeed sounds like an unintended outcome of a recent change.
I’m raising this for discussion internally and we will get back to you soon about this.

Kind regards,

I would like to let you know that earlier this week we released a fix for this on production.
At the moment you will still get the option to change the target release of the fleet from the fleet summary page even while a new release is building.
Moreover, we have also added this as an option in the fleet settings page.

Thanks for raising this & let us know how it works for you.

Kind regards,


Thanks, works now again as expected!