Seem to have run out of tasks?

After setting things up during Happy Hour yesterday and running well into the night, I appear to have run out of tasks this morning? The FAQ said that sometimes they are exhausted and to check https://boinc.bakerlab.org/rosetta/server_status.php but it seems that there are plenty available? I poked around in the menu etc. but couldn’t figure out what might be going on - help? :sweat_smile:

Also, where can I find docs about what’s going on underneath? e.g. I’m not even sure how to ssh (doesn’t seem to be enabled) or otherwise connect to the box other than via http://foldforcovid.local/ - so I couldn’t do much investigation on my own. Thanks in advance for your help! :heart:

1 Like

I found the GitHub repo and this suggestion:

If you are not receiving work units, in boinctui try pressing F9 -> rosetta -> update.

but it said Not requesting tasks- even when I manually selected Allow new tasks - any ideas? :sweat_smile:

1 Like

Same problem here with Raspberry Pi 4 2GB of RAM.
Maybe the system is short in 2GB tasks?
Which model is your board @ishotjr ?

1 Like

Also 2GB! :male_detective:

1 Like

I have seen a few reports of needing a reboot, I will investigate the container today…meanwhile, try rebooting and see if that works. Thanks!

1 Like

Oh, hi David! :grin: I left it for a few days because I was unsure how to power down safely and hoped maybe it would fix itself, but earlier today I finally broke down and yanked the cord; on restart, I ran into this and wasn’t sure how to re-join with the existing account, so I created a new one on the same team and things are working again for now. I have a bunch of detailed notes etc. so please let me know if there’s any info I can provide to help diagnose/if I should open a GitHub issue/etc. - thanks! :rocket:

Awesome, yes, if you could share them here and open up any relevant GH Issues that would be excellent!

Cool - will do! :heart:

Ooooof - no new tasks again after the first one completed today. :man_facepalming: Tried updating, resetting, etc. and the only thing that works is detaching and re-adding! :weary: I’m wondering how many others are experiencing this, and how many machines that aren’t being monitored just stopped helping after their very first task? :worried:

Same problem here. With a 2GB Raspberry Pi 4.
First, I tried it with the pre-made image from https://foldforcovid.io/
After that, I went with a full deployment on balenaCloud and github Rosetta. After two days or so of everything OK, the Raspberry Pies wasted more than 12 hours without receiving any task. Now, restart and two new tasks are received immediately.

1 Like

One more, out of work after the single task completed. My next move was going to be exactly what you described, so that’s frustrating to learn it won’t help. Will continue to share my findings here - thank you for doing the same! :heart:

There are an issue related to this in the GitHub repo:

I don’t know if they find a solution and when they can deploy to the project.

1 Like

I saw that - but is 2GB really “low memory”? The project advertises as Pi3 compatible, which has a max. 1GB, and all Pi4s except the rare 4GB model have 2, or just 1GB?? :confused:

The GitHub repo is updated. Maybe this work better.

1 Like

I have three pi3s and three pi4s up and running but none of them are processing anything because there are no tasks for the pi3 due to low memory availability and the pi4s stop after one job with the message “not requesting tasks”. I might as well power them all off if they aren’t going to do anything. Can someone fix all this so we can really contribute please?

1 Like

Hi Jeff,

We have identified a fix for this, and it will be rolled out as part of the next release: https://github.com/balenalabs/rosetta-at-home/issues/22

Thanks!

Thanks @dtischler - so to clarify is this in the balena-cloud-rosetta-at-home-arm-raspberrypi4-64-2.48.0+rev1-v10.8.0-1344795.img.zip image available for download right now? (I’m guessing not, since that’s the same filename as I downloaded on the 17th; follow-up question then I guess is: when is the next release? :sweat_smile:)

update: learned on the stream today that the fix s/b distributed OTA by EOW! :rocket: :soon:

1 Like

I restarted my device around noon Eastern time today, and when I checked it just now (11h later) it was 18% into a new 10H task - i.e. for the first time ever, it’s successfully fetched new tasks after completing the first one - awesome!! :rocket: :tada:

2 Likes

@ishotjr that’s great news, thanks for letting us know the fix has helped! :smiley:

1 Like