Screenly - Balena not working

Hi there.

I’m new to Balena, I’ve been trying to install Screenly via Balena using this tutorial here. My device is working and registered into balena cloud.

While trying to do balena push .. it does start creating the different containers but then it failed while building screenly-viewer below is the log, seems that it fails just after CMD ["bash", "/tmp/screenly/bin/"] that’s the last line in the Dockerfile.viewer.template [here]

[screenly-viewer]       Stored in directory: /root/.cache/pip/wheels/33/f3/71/58912e32ec10e245ab5e438e2d965e8ae47818335a0f9487ac
[screenly-viewer]       Building wheel for PyYAML ( started
[screenly-viewer]       Building wheel for PyYAML ( finished with status 'done'
[screenly-viewer]       Created wheel for PyYAML: filename=PyYAML-5.3.1-cp27-cp27mu-linux_armv7l.whl size=45644 sha256=c9c27ab51d11a834c23b033ae68ec0804866d6ad8d922007d7bd432eb36b3c58
[screenly-viewer]       Stored in directory: /root/.cache/pip/wheels/d1/d5/a0/3c27cdc8b0209c5fc1385afeee936cf8a71e13d885388b4be2
[screenly-viewer]       Building wheel for billiard ( started
[screenly-viewer]       Building wheel for billiard ( finished with status 'done'
[screenly-viewer]       Created wheel for billiard: filename=billiard- size=112404 sha256=ef2c712bad12ac9e186b733bec1dde1432357156a66ae2c10e7418dfd19a5cd7
[screenly-viewer]       Stored in directory: /root/.cache/pip/wheels/88/11/53/9af62f156761361089955e143a92658fdd8947d24389b0f15b
[screenly-viewer]       Building wheel for greenlet ( started
[screenly-viewer]       Building wheel for greenlet ( finished with status 'done'
[screenly-viewer]       Created wheel for greenlet: filename=greenlet-0.4.16-cp27-cp27mu-linux_armv7l.whl size=36109 sha256=b04f47b20ba11e9f1babe4a4b5f099cc57bf5596ef2df074d8c69f0b168a0464
[screenly-viewer]       Stored in directory: /root/.cache/pip/wheels/c8/c2/b8/7e60d1e48e5e507d52cda38a74dbed29aafc0135ace48470cf
[screenly-viewer]     Successfully built Mako MarkupSafe ansible cffi configparser cryptography flask-restful-swagger-2 flask-swagger-ui gevent-websocket gevent hurry.filesize psutil pyasn1 pytz pyzmq sh uptime PyYAML billiard greenlet
[screenly-viewer]     Installing collected packages: MarkupSafe, Mako, jinja2, PyYAML, ipaddress, six, pycparser, cffi, enum34, cryptography, ansible, vine, amqp, kombu, pytz, billiard, celery, certifi, click, configparser, itsdangerous, werkzeug, flask, Flask-Cors, aniso8601, flask-restful, flask-restful-swagger-2, flask-swagger-ui, futures, greenlet, gevent, gevent-websocket, gunicorn, hurry.filesize, mixpanel, psutil, pyasn1, pydbus, python-dateutil, pyzmq, pyOpenSSL, redis, chardet, idna, urllib3, requests, sh, uptime, youtube-dl
[screenly-viewer]     Successfully installed Flask-Cors-3.0.4 Mako-0.7.3 MarkupSafe-1.0 PyYAML-5.3.1 amqp-2.6.0 aniso8601-8.0.0 ansible-2.8.8 billiard- celery-4.3.0 certifi-2018.4.16 cffi-1.13.2 chardet-3.0.4 click-6.7 configparser-3.5.0 cryptography-2.8 enum34-1.1.10 flask-1.0.2 flask-restful-0.3.6 flask-restful-swagger-2-0.35 flask-swagger-ui-3.0.12 futures-3.0.5 gevent-1.2.2 gevent-websocket-0.10.1 greenlet-0.4.16 gunicorn-19.8.1 hurry.filesize-0.9 idna-2.8 ipaddress-1.0.23 itsdangerous-1.1.0 jinja2-2.10.1 kombu-4.6.3 mixpanel-4.3.2 psutil-5.6.7 pyOpenSSL-19.1.0 pyasn1-0.1.8 pycparser-2.20 pydbus-0.6.0 python-dateutil-2.4.2 pytz-2012d pyzmq-16.0.2 redis-3.2.0 requests-2.22.0 sh-1.8 six-1.11.0 uptime-2.0.2 urllib3-1.25.7 vine-1.3.0 werkzeug-0.15.3 youtube-dl-2020.6.16.1
[screenly-viewer]     Removing intermediate container 4a954c1d14d6
[screenly-viewer]      ---> a1c1aa888bea
[screenly-viewer]     Step 5/8 : COPY ansible/roles/screenly/files/gtkrc-2.0 /data/.gtkrc-2.0
[screenly-viewer]      ---> 84fc0c1cf2b3
[screenly-viewer]     Step 6/8 : COPY . /tmp/screenly
[screenly-viewer]      ---> 7f68f031712d
[screenly-viewer]     Step 7/8 : CMD ["bash", "chmod 777 /dev/vchiq"]
[screenly-viewer]      ---> Running in 875aa48779cc
[screenly-viewer]     Removing intermediate container 875aa48779cc
[screenly-viewer]      ---> 6dc3ae6b8cdf
[screenly-viewer]     Step 8/8 : CMD ["bash", "/tmp/screenly/bin/"]
[screenly-viewer]      ---> Running in 514d74769ef4
[screenly-viewer]     Removing intermediate container 514d74769ef4
[screenly-viewer]      ---> 4313d2245813
[screenly-viewer]     Successfully built 4313d2245813
[Info]                Generating image deltas from release ce501cd8c50947d0b5a61f83b3ffa268 (id: 1422780)
[Success]             Successfully generated image deltas
[Info]                Uploading images
[Error]               An error occured: (HTTP code 404) no such image - no such image: d1a5fb5edfc5: No such image: d1a5fb5edfc5:latest
[Info]                Built on arm03
[Error]               Not deploying release.
[========>                                          ] 17%Remote build failed

Any ideas what’s wrong with the build?


It’s not a problem specific to you, we are discussing it in Build fails with error - no such image and other threads

Hi @Mauricio,

If you have docker installed on your system you might want to try running balena deploy app-name as this avoids using the Balena servers. If you have any trouble building use the --emulated flag.

The deploy approach is not ideal but it is the work around that we have had to use at our company to get things onto device.

More information can be found in the Balena CLI documentation:

All the best

1 Like


There was an issue with our builders yesterday, please check this incident report for more details. A fix for it was deployed and it should be working properly now.

I’m sorry for the inconvenience and please let us know if you need further support .

Kind regards,

Thank you very much, I tried it today and worked just fine.

thanks @hpgmiskin this also worked for me locally.

Glad to hear you got it working. :slight_smile: