Balena Raspberry Screenly Error


I have a problem executing the command balena push “First-Fleet”

load everything fine about 10 minutes but in the end there is an error

[Info] Uploading images
[Success] Successfully uploaded images
[Error] Some services failed to build:
[Error] Service: srly-ose-server
[Error] Error: The command ‘/bin/sh -c pip install --no-cache-dir -r /tmp/requirements.txt’ returned a non-zero code: 1
[Error] Service: srly-ose-celery
[Error] Error: The command ‘/bin/sh -c pip install --no-cache-dir -r /tmp/requirements.txt’ returned a non-zero code: 1
[Info] Built on arm03
[Error] Not deploying release.
Remote build failed

Please Help Me

Hi @jegm96,

You can take a look at the build issues via --debug flag when running standalone build like: balena build --debug ...

An example of a full command for Rpi3:

balena build --debug --deviceType raspberrypi3 --arch armv7hf --emulated .

Try the above and let us know how it goes.


I’ll try and let you know
one thing that I forgot to mention that when I turn on the Raspberry with the Balena os image, my raspberry does not appear anywhere on the dashboard, do you know what the problem could be?

Hi @Jegm96,
and a warm welcome to the balena forums. :grinning:

You could check your network settings, this inidicates that the device is in some way not able connect to the balena cloud.

A simple reflash with the add device dialogue could help.

Regards Markus

1 Like

A simple reflash with the add device dialogue could help.

This is good advice! It’s reasonably common for devices to be flashed with unmanaged OS images which don’t connect to the dashboard by default, but those obtained via the ‘Add device’ modal in the dashboard will.

I already linked my raspberry with balena, but now I have this error when performing push

1 Like

Good news! @Jegm96

The Screenshots show the output of the balena push fleetname command. The good news here: your device is not the source of the errors that are showing up there.
A complete output from the command would help me analyzing what failed, but have a look at the lines that say:
[Error] Error: The command "/bin/sh -c pip install --no-cache-dir -r /tmp/requirements.txt' returned with non-zero code: 1

This indicated, that the build process failed executing /bin/sh -c pip or simply pip.
From the folder path given in your screenshots, I assume you are running this on a windows machine, in a windows cmd.

After consulting my favorite search engine, I found following issue on screenlys github page.

There is already a commit for this issue regarding a dependency for screenly-ose. For now, you could patch the change yourself by editing the stated file as follows: requirements/requirements.txt
In the file change celery==5.2.2 to celery==4.4.7. Then try again with balena push ...

Hope this will to the trick for you :smile:

Regards Markus

Excellent, it worked for me to change the parameters of requirements/requirements.txt

I thank you very much

Hi @Jegm96

Cool that this worked out as expected. Feel free to mark my answer as solution to close this thread.