Rtl8812au antenna - 5GHz hostapd

Hi all,

I have some wifi antennae with different chipsets. I am trying to broadcast a 5GHz networking using hostapd. I have a couple of antennae that should be capable of this both with the RTL8812au chipset but I’m finding it difficult to get them working (ResinOS 2.3.0).

Using this: https://github.com/bjorn-sminq/rtl8812-resin-module, running bash build.sh raspberrypi3 '2.3.0+rev1.dev' rtl8812au_rtl8821au I get Could not find headers for 'raspberrypi3' at version '2.3.0+rev1.dev', run build.sh --list which is stange because build.sh --list shows the device and version.

Secondly, I saw this antenna pop up in a few threads: https://www.amazon.co.uk/gp/product/B01C2N2O8S/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1 Can anyone confirm it’s working with hostapd for a 5GHz network?


I am not familiar with this project but looking at build.shs code, it looks like the device type and version you pass to it are regular expressions. This means that you need to escape the dots and plus in the version:

./build.sh raspberrypi3 "2\.3\.0\+rev1\.dev" rtl8812au_rtl8821au

This makes the Could not find headers for 'raspberrypi3' at version '2.3.0+rev1.dev', run build.sh --list error disappear but then I get a new one:

ERROR: images/raspberrypi3/2.3.0+rev1.dev/kernel_modules_headers.tar.gz: Could not retrieve https://files.resinstaging.io/images/raspberrypi3/2.3.0+rev1.dev/kernel_modules_headers.tar.gz, skipping.

I’ll ask the team why these files are not accessible.

As a workaround you should be able to get these headers using minio's mc command:

mc cp s3/resin-staging-img/images/raspberrypi3/2.3.0+rev1.dev/kernel_modules_headers.tar.gz .

You can get mc from there https://www.minio.io/downloads.html#download-client .

Thank you @zvin, I will give that a shot!

@prash I see that the build.sh script in your project is from 8 months ago, but the original example on github has a newer version that added support for versions with + in the name (i.e. pretty much all the 2.x devices). Maybe you’d like to take that new build.sh version, and git that one a try?

Hi @imrehg

With your suggestion build.sh runs and exits with no error. kernel_module_headers.tar.gz downloads successfully, but then make stops:

  make: Entering directory '/tmp/tmp.asIhjMBhge'
  Building modules, stage 2.
  MODPOST 0 modules 
  make: Leaving directory '/tmp/tmp.asIhjMBhge'

With apologies that this thread has gone quiet for a little while, where is this one up to? Is it still as last stated?

Yes, I couldn’t find a solution. Ended up using different hardware with a different chipset that worked.

Me too I’m interested in having the rtl8812au working.
I’m stuck on the same error, right now.
Still investigating.
Maybe some solved this case in the meantime?