RPI4 4GB Only 3 tasks processing at once.

Hey hey, I’ve got 10x RPI4 4GB and they are all only processing 3 tasks at once, I assuming ideally it could process 4 tasks at once (one task per core). I’m just wondering if this is expected due to limitations on this unit or a setting I have missed?

Edit: I will note I notice this text.

“Preferences:
max memory usage when active: 3663.19 MB
max memory usage when idle: 3663.19 MB
max disk usage: 12.53GB
max CPUs used: 3”

Kinda makes me think I need to edit a pref somewhere :wink:

Kind regards

Hi John,
This is set to 75% of processing resources by default, however it is possible to remove this restriction by setting the env var SKIP_BOINC_CPU_SETTINGS_CHECK to a non-empty string. This protection was introduced to prevent a possible situation where the device may enter a reboot loop if all the memory gets consumed (which may happen if all cores are maxed out). We’d be very interested to hear how you get on though with this setting!

You can manage env vars across the fleet easily using either the dashboard or the cli:
https://www.balena.io/docs/learn/manage/serv-vars/

Thanks a heap mate, that solved it.

Name = SKIP_BOINC_CPU_SETTINGS_CHECK and Value = 0

All 10 units are now processing 4 tasks each. I’ll keep you in the if I run into any reboot loops or other issues. Can understand why this was implemented as I assume most are running 2GB Pi4’s and 4 threads would certainly max out the ram.

Thanks again :wink:

Regards Patto

Great, glad it’s working! Yes, please do let us know if you have any issues with this (or if it continues to run stably, which will also be useful info!)