RPi 4 no sound from jack on BalenaOS 2.98.33

i had a problem with no sound going out from rpi4 and i could not find the solution until i found that parameter “Define DT overlays” had value “vc4-kms-v3d” which is doing this bug (?)

I also tried to put variable “AUDIO_OUTPUT” with value “RPI_HEADPHONES” thats does not help

I also tried to change the value of dt overlay to “vc4-fkms-v3d” THIS helped but i have no idea if i can leave it like this. Also if i remove this value completely and leave it blank it also working.
This only happened on this new balenaOS 2.98.33 update
I have working rpi 4 with no problems with balenaOS 2.80.3+rev1 which have fkms not kms parameter but this one had it default . The new one with newer HostOS not.
Thank you in advance :slight_smile:
screen shot over heeere with errors i have found with kms
im newbie to these things so sorry if i say something wrong :slight_smile:
have a nice day

Hello @tiedrop

Glad you found a solution.
There should be no risk at running with fkms.