Requires privilage login to flash SD card?

I am trying to use balenaEtcher to flash an new OS onto a SD card for my RashberryPi but when i tried to flash the img to the drive a log in box appeared stating the needs “balenaEtcher privileged access in order to flash disks”?

i am using a 27" Imac with MacOS Monterey 12.6

Hi Paul,

Privileged access is indeed required to access any disk storage at “raw level”, which is needed to write an image to a SD card. Writing an image is a form of “wiping and replacing every data on a disk”, you don’t want any program to be able to do that.
This is standard security to prevent programs to get basically full access to your disk, read/write data or wipe your entire disk.

You can enter your credentials, don’t worry, it is handled at OS level and etcher don’t store them nor access any unwanted content. If you have any doubts, balenaEtcher is open-source, feel free to have a look at the code here.

When I tried to flash as non-administrator, the Acronis watcher blocked Etcher, saying the program was trying to write the MBR “on your disk”.
Running as administrator worked fine.
Naturally, Acronis didn’t tell me which disk. Presumably Acronis became upset when Etcher wrote on the fancy system blocks on the output “disk”, which was actually an SD card.

Thanks for the update. I understand administrator access for a program might be scary.
But as long as you get it from the official website or git repository, you exactly know what’s in the program (from the git repo).