Reflash eMMC on Upboard

So I flashed my upboard which worked well, but now I want to put a prod resinOS on the device and I’m having trouble. I tried going through the same process (plug device into monitor, keyboard, etc and then hold f7 during boot with the new image flashed on an attached USB) but it just keeps booting the dev image that I originally flashed.

How can I flash a new resinOS onto the eMMC memory on the upboard?

Thank you!

Do you see the boot menu on boot, or does it just go straight to the existing ResinOS bootup? Flashing a new image should behave exactly as it did the first time.


I see a boot menu briefly, but it only has boot as an option even though the flash drive is attached. It then boots right into resin.

Is the image on the USB “known good”, is it convenient to test that same USB stick in a different Upboard?


Sorry for falling off on this. I switched back to the Pi because I couldn’t get this to work. I don’t have another upboard to try it on, but I’ve used 4 or 5 different USB sticks and have tried downloading new images and using those, all without success.

Here’s an overview of the behavior I’m experiencing in case it is helpful to the Resin team or anybody that is dealing with something similar in the future. I’m recounting from memory so it’ll be rather high level.

I successfully flashed a dev image onto the Upboard and it was working as expected. Then, when I went to place a prod image onto the board, I went through the same process as before. However, after selecting the boot drive and booting up the device, I was met with an error that indicated an overlap in the partitions. Now, when I boot the device without selecting the boot drive, I’m brought driectly to the grub cli and when I attempt to flash a new image (either dev or prod) onto the UPboard, I can select the boot drive and then, after selecting the drive for it to boot from and rebooting the device, I’m shown the same partition overlap error.

If more details would be helpful I’m happy to grab the device and send over error messages etc.


I believe I was seeing an issue similar to you. It seems once an OS is installed on the UP Board it switches the default boot order over to emmc. So, to re-install I alternated pressing F2 and Delete until the BIOS password dialog shows up. Press Enter to use a blank password. Next, head over to the Boot screen to control the boot order.

Hope that helps!