RaspberryPi 3 - Microservices - Development image not booting

Hi there,

I wanted to start playing with the new microservices application type.
I have a RaspberryPi 3.
I can get my device online with the Production image, but I can’t get it to boot with the development one.

It hangs on boot-up. The led flashes 6 times then nothing anymore. It’s connected with LAN, and monitor on HDMI.

This is what’s on the screen : L

Any idea ?

I tried both 2.12.5+rev2-dev-v7.1.18 and 2.12.5+rev1-dev-v7.1.18 - same result.


Hi Xyala,

I just tested a RPi3 2.12.5+rev2 development image from the dashboard and it works fine.

Please try again to flash your card or use a different SD card because they can get corrupted.

Using a serial cable could also help you diagnose your problem.


Ok, tried it again and again, wasn’t working.
I now tried it again and it worked. I did tried with two different cards also. Strange.

The one different from before is that for the very first boot of the Pi with the dev image I unplug a serial connection I had prepared on the GPIOs.
Could that be what interfered with the initial boot up ?

If the GPIO was somehow wired up incorrectly, it could indeed cause issues with the initial boot, but it is hard to tell.

ok. If I have time I will double check / redo some tests.
Not that it’s a big issue in my case. But could help others to trouble shoot.

Case closed :slight_smile:

Yeah, if you have time that would be great to know/investigate :slight_smile:

So! I did make a test since I was flashing a new image …

(unrelated, but seems that activation HDMI log - [RESIN_HOST_LOG_TO_DISPLAY] - plunged my device into an infinite reboot loop. – that will be for another investigation tomorrow…

So that new image.
Plugged the 2 cables. I’m using serial UART (connections made on ground and GPIO15).
When you boot up for the very first time, it stays stuck (same as earlier).
Now, without rebooting. As soon as I disconnect GPIO15, it continues to boot up, registers on resin and starts downloading it’s things.

Note: it isn’t an issue anymore on future reboots.

Now, I also tried once more with a new image and this time disconnected the cable and reconnected right away once it had started going again. A lot appeared ont the screen and it restarted. I couldn’t take a picture. ^^


Other question (slightly related maybe).
What’s the difference between [RESIN_HOST_CONFIG_enable_uart] to enabled and also having to add RESIN_HOST_CONFIG_dtoverlay = pi3-miniuart-bt ?

did some further digging.
So basically it happens only on the Pi3 with dev images.

Also. I stopped using the dev images on both my Pi2 and Pi3
It’s related to this : Disable console over Serial in Dev on RPi3?
And I couldn’t figure out a good solution for it actually to work “stable” just like it does on the prod image. So I’m back at doing lots of comits / git push resin master instead of resin sync.
Serial is too much of a pain to get working properly with the dev images (sorry guys), so prod it is for me.