Raspberry Pi Zero 2w

Hi all,

I’ve not found yet a topic on the following subject (still searching…), therefore my apologies if this is kind of duplicated from somewhere.

Using Rpi Zero 2w I can flash an SD card with BalenaOS production mode as usual.
But if I flash the same with development mode, the device never reaches the Balena Fleet.

I’v tested with several different devices and SD cards.
When I turn the devices on and run balena scan, only devices running production mode appear on the search.
Also, even running an arp-scan doesn’t show the devices on my network. I’ve tested in two different networks, using two different routers, just in case.

It seems that somehow the BalenaOS is not running or stuck somewhere.

If you have any good advice on this, I’ll apreciate.

Thanks in advance


Hello @suporte could you please confirm the balenaOS version that you are testing?


On the other hand, did you try to configure the production OS and modify the developmentMode flag to true? That might convert your Production OS to Development. Let us know if this works.

You can find more information here Configuration - Balena Documentation

Hi @mpous and thank you for the quick reply.

I tried last week with the version:

This is the image which I flashed

Hope this answers your question

I didn’t try that.
I’ll do it and let you know if it does the job!

Thank you

1 Like

Hi, Running into the same issue. Just tried Production Mode with developmentMode: true and no luck

Using balenaOS 2.113.29

with Wifi + Ethernet.

The device sends it’s first heartbeat to the dashboard and show’s up in the dashboard but then remains unseen after that with No logs

Plugging in an HDMI show’s the initial splash screen, then an initial console. Then it looks like the device is constantly rebooting.

Etcher version: 1.18.4

Just tried with a ProductionMode Image as well and it also did not work.

the previous version available in the dashboard: balenaOS 2.105…21 works just fine

Nevermind it just gets 1 step further and reports an initial config log before thrashing

Had to go all the way back to:
balenaOS 2.87.16+rev1

to get a working version

Hi all,

I’ve tried with success with BalenaOS 2.105.21 (not the recommended one).
It worked both in production and in development mode.

BalenaOS 2.113.29 is working in production mode but didn’t try in development mode still

Hi all and again!

It seems that there’s some issue with the latest balenaOS versions vor raspberry pi zero 2W (64 bit).
I’ve just flashed 3 different SD cards for 3 different devices with:

  1. BalenaOs 2.114.18 (recommended)
    production mode ethernet only

  2. BalenaOs 2.114.18 (recommended)
    production mode ethernet + wifi

  3. BalenaOs 2.113.29+rev1
    production mode ethernet only

  4. BalenaOs 2.105.21
    production mode ethernet only

And only this last one worked, meaning that only the last one reached balena dashboard

Hope you can figure this out
Best regards!

Hi, the raspberrypi0-2w-64 is one of the devices that are automatically tested on each release. That means that before deployments they go through a comprehensive set of tests. Also for the record, on balenaOS releases above 2.85 there is a unified image, and production/development is only a configuration option.
Would be nice to see the journalctl --no-pager output of one of the failing cases if a serial console can be attached in development mode.

Checking in 2 months later with 2.115.18+rev2 It’s still not working sends a first heartbeat and then hangs at No logs received.

I’m happy to hear that the devices are automatically tested but there may be a disconnect here still, would you be able to try to launch a device yourself from the dashboard to see if it works, not just the automated testing?

I don’t have spare serial cable right now but I’ll try to get a serial journal output for you some time this week if it’s available.

ETA: 2.87.16+rev1 still works like a charm

@carottid I’ve been using balenaOS 3.0.8+rev2 for the Zero 2W for the past few days and it has no problem booting and seems very stable. Can you give that version a try and let us know if it works for you?

Hey, the 3.0 versions seem to be working for me. looking back I think I might have been testing everything on a deadbugged pi, so things were probably my fault however I no longer have the pi to test with.