Raspberry pi camera not working on fin V1.0

Hi! I tried interfacing Raspberry pi camera v1.3 with balena fin v1.0. But unfortunately the fin is not detecting the camera. When i use raspi still command. I’m getting mmal errors and when i use vcgencmd get_camera command it supported=0 detected=0. I tried changing the config files. But nothing worked. Kindly help me to solve this issue. Thank you!

Hello @Zeus, what OS are you using?

Hello. I’m using Raspbian os.

Hi there, at your message you mention you get some errors.
Could you please attach them here?

Hi! I’m trying to interface raspicam v1.3 to Balena Fin v1.0. I have resolved some issues and finally the camera gets detected. But unfortunately, when i use raspistill command it returns some error. I googled regarding the error and tried connecting with Raspberry pi. The camera works fine with pi. But returns error with Fin. Kindly help me to solve the issue.Thank You!

Hi there, there’s a couple of things to check here:

  1. Have you tried using the camera with the Pi since trying it with the Fin? If you try it right now does it work with the Pi?
  2. Have you tried disconnecting and reconnecting (while power is off!) the sunny connector - the yellow part under the camera?
  3. The error can appear if another application is trying to use the camera
  4. You could try using dmesg to see if there is anything troubling that could give us some clues

Thanks for your response. I tried connecting the camera with pi after disconnecting it from fin. The camera worked fine. Also i connected and disconnected the camera only when the power is off. Also I checked using dmesg and no background process is using the camera. Also i have booted the preconfigured Raspbian fin os which i found in getting started with balena site.

Which connector is the camera connected to? Cam0?

Yes cam0. The port which is denoted as camera in the fin.

Also i tried flashing the latest raspbian os from Raspberrypi site and loaded the dt-blob.bin file into the /boot folder. The camera gets detected but the above mentioned issue still exists. But the camera is working fine with pi. The issue persists only with the fin. Kindly help me to solve the issue. Thank you!

Hi there, to rule out a potential issue with our Raspbian OS build, could you please try to build and deploy https://github.com/balenalabs/balena-cam project to the Fin to see if that works?

Sure sir. I’ll try and let you know about the results soon!