Pull and Run a container with balenaEngine


I m very new in balena. I just use the first two commands from this link https://www.balena.io/engine/docs/ (pull an image and run it after downloaded).
The pull it runs succesfully(the images are downloaded) , but when i want to run the images, the output is :
Adapter not found, trying alternative
Adapter not found, trying alternative
Adapter not found, trying alternative
Adapter not found, trying alternative
it shows this message continuously

The commands i run are the same as the link but with different image.
I already run some containers in my device, but i did that using balena CLI with the command push a docker-compose file.
Now i try to add one more container and run it by using the terminal of my device and the balena-engine.


Hi @xamsak,
Could you share a few extra info about what you are trying to do?
First let’s clarify whether you using balena-engine directly on your computer or inside a balenaOS device.
Can you share the exact command that you are running, along with the image if that’s public (or a public base image that you might be using as a base)?
What version of the OS are you running and on what kind of device?
Is the device running a plain balenaOS image (downloaded from the balena-cli or the balenaOS site) or was it downloaded from the balena-cloud dashboard?

Kind regards,

I run a balenaOs (Type Intel NUC) in a virtual machine. so i use balena engine inside a balenaOS.
The version of balena is : balenaOS 2.36.0+rev2
The balenaOS image was downloaded from balena-cloud dashboard.
Using balena cli i have already push a docker-compose file. This file have the instructions for the images of a project called “EdgeX” . There are lot of containers that are running Separately and every container is running a specific service.
Now i just want to add one more service (so one more image), that i didnt have it in the docker-compose file that i used firstly.
So i want to try some things like to download and run (locally) the new image that i want ,from the terminal of the device.
Or to do the same thing but using the balena cloud registry and not locally (this is the next that i will try)
The exact commands that i run are :

  1. balena-engine pull edgexfoundry/docker-device-bluetooth
  2. balena-engine run -it --rm edgexfoundry/docker-device-bluetooth /bin/bash

The command 1 is ok. It downloaded the image i asked, and i can see it when i use the command balena-engine images
But the command 2 gives the output that i told you before ( Adapter not found, trying alternative)
I tried to run it with different syntax but sometime gives error ERRO[2019-06-27T11:41:44.399398581Z] error waiting for container: unexpected EOF or the same i told you ( Adapter not found, trying alternative)

Thank you very much,

Hello @xamsak ,

balenaOS contains a Supervisor, which is a service that queries our API backend and determines exactly what services make up an application (the services specified in the docker-compose.yml provided when you git push or balena push to our Builder). The Supervisor ensures that only these services are running, so any attempt to ‘go around’ the Supervisor and manually run services in the host OS will fail (the Supervisor will immediately try and kill that service). I suspect the error that you’re seeing is a manifestation of this.

The correct way to proceed is to add the missing service to the docker-compose.yml file and git push or balena push it again. Whilst this can obviously take some time via the balenaCloud service, you can do this locally (as you mention), which will build the services and start running them via your local network. This is achievable by going to the Dashboard page for your device, selecting Actions and then Local Mode. There is some documentation on this here: https://www.balena.io/docs/learn/develop/local-mode/ Note that switching to Local Mode will stop running the services from balenaCloud.

If you want to use baleanEngine manually to run services, then the best place to start would be to use an unmanaged balenaOS image, which you can download from here: https://www.balena.io/os/

Hope this helps, let us know if you have any other questions!

Best regards, Heds

Thanks Heds,

I will try to see the things you said.
Just one thing you said i have already did it. I pushed a new docker-compose file , adding the missing service but my device is not running in the device.
After that i added one more device in the application (with the same characteristics) and the new device is running the missing service.
I dont why happens this. I have two devices now in the same application that dont run exact the same services.

Best Regards,

Hi @xamsak ,

By default, the balena Supervisor checks for updates every ten minutes (when downloading a provisioning image from the Dashboard via ‘Add Device’, if you select the ‘Advanced Settings’ option, you’ll see that there’s a ‘Check for updates every X minutes’ editfield, which by default is set to 10). You should see your first device download the Application somewhere up to ten minutes after you pushed the changes.

If you haven’t, then if you PM me with the Dashboard URL for the device having trouble, we can look into it and see what’s occurring.

Best regards, Heds

Sorry, one last point, if you want us to check the device, please also grant support access for it. You can do this by going to ‘Actions’ and then ‘Grant Support Access’ for a period of time (24 hours is usually a good default).

Heloo Hedss,

The Dashboard url is : https://dashboard.balena-cloud.com/devices/0f5bbe6e5a5eaad63ea14e6a3dbfed2b/summary

I also push grant support access for it, for 24 hours.

Please inform me when will you want to check it, so to start the device and be online.

Thank you very much,


Απαλλαγμένο από ιούς. www.avast.com

Στις Πέμ, 27 Ιουν 2019 στις 4:17 μ.μ., ο/η Heds Simons via balenaForums balena@discoursemail.com έγραψε:

Did you do something in the device i sent you?
cause just now it started to make update and download and install the new image that i want it.

Best regards,


Απαλλαγμένο από ιούς. www.avast.com

Στις Πέμ, 27 Ιουν 2019 στις 9:04 μ.μ., ο/η Sak Xam xamsak@gmail.com έγραψε:

Hi @xamsak, I was taking a look at the device and it started downloading the release of its own accord.

Hi Chrisys,

I see it,too…but it stuck in 53% the last half an hour… I dont know what happen.


The network your device is on seems a little intermittent which could be the cause of some of the issues. Can you check and confirm the network is working correctly?

The internet connection is ok. The device is a Vm that i run on my computer and use my internet connection.
I made a restart. I did not make any change general. The status is “updating”.
I also made a ping from Host Os terminal(in device dashboard) and seems is everytting ok.
I will check it tommorow with a different internet connection

Hi there,

We were digging into your device further but after many disconnections it appears to be either totally re-provisioned or support access has been disabled. Would you mind reenabling access and letting us know when we are able to keep digging?

Thank you!

Hello there,

I think its better to delete the application and i will add new application and new devices.
If this problem appear again i will inform you again.

Best Regards,

Ok. Yes please let us know if the problem appears again.
Best regards