Problem with device type "raspberry-pi2"

Hi, I am getting a timeout error when I deploy my application to fleet with device type “raspberry-pi2” on our openbalena server.

[Build] gateway Step 1/7 : FROM balenalib/raspberry-pi2-debian-openjdk:11-bullseye
[Build] gateway —> f7233e87ef2e
[Build] gateway Step 2/7 : EXPOSE 8080
[Build] gateway —> Using cache
[Build] gateway —> 7ab8013cdc70
[Build] gateway Step 3/7 : RUN pwd
[Build] gateway —> Using cache
[Build] gateway —> 4837c503d639
[Build] gateway Step 4/7 : RUN mkdir /opt/app
[Build] gateway —> Using cache
[Build] gateway —> 090edaf86e08
[Build] gateway Step 5/7 : COPY target/*.jar /opt/app/gateway.jar
[Build] gateway —> Using cache
[Build] gateway —> df99d38c95b9
[Build] gateway Step 6/7 : WORKDIR /data/zstech-gateway/
[Build] gateway —> Using cache
[Build] gateway —> 9ccff5f11bc4
[Build] gateway Step 7/7 : CMD [“java”, “-jar”, “/opt/app/gateway.jar”]
[Build] gateway —> Using cache
[Build] gateway —> e68f5789ccc0
[Build] gateway Successfully built e68f5789ccc0
[Build] gateway Successfully tagged ch.zstech.gateway_gateway:latest
[Build] gateway Image size: 508.38 MB
[Build] Built 1 service in 0:08
[Info] Creating release…
[Info] Saving release…
[Error] Deploy failed
(HTTP code 500) server error - i/o timeout

Deploying to a fleet with other device type, e.g. revpi-core-3 works as expected.

The server has version 3.6.0 installed and the CLI version 13.5.3

But when I create the fleet with device type “raspberrypi2” (without dash), everything works like expected. Even the device, I have to configure with the device type “raspberrypi2”.

Is there a reason for that missmatch in device type names and is it documented somewhere?

Thanks for reaching out. This is a weird one. We tried reproducing on balenaCLI versions v13.2.0, and v13.5.1 running on balenaCloud and didn’t see this issue. Could it be a case where the issue is openBalena specific? According to CLI docs, this should have worked out while creating a fleet: balena CLI Documentation - Balena Documentation

Context: It seems that for you, the build is working for only the alias of the device as mentioned in our device contract but not for the slug of the RaspberryPi2 device type. Usually, things should work just fine with slugs or aliases interchangeably as we were able to reproduce on our side. Device contract: contracts/contract.json at master · balena-io/contracts · GitHub

Can you confirm if your current setup works when working with balenaCloud just as a way to narrow down the problem further? Alos, it be really helpful if you can provide all the steps you using to create and push fleets for us to reproduce this scenario accurately

I created the fleet with the Balena CLI with this command:

balena fleet create myFleet2 --type raspberry-pi2

and then I tried to deploy with:

balena deploy myFleet2 --build

When I now tried to reproduce the issue to provide the steps to create and push fleets, I was not successful. That means, that everything works like expected now. I can’t explain, why it works now, but didn’t before. Except in the meantime I restartet the computer where the Balena CLI is running on. Unfortunately, we only use OpenBalena and can’t test with balenaCloud.

Thanks anyway.

1 Like

It’s great to see that it worked properly @luclucluca :slight_smile:

Let us know if we can help you more!

1 Like