Problem building a node.js app that needs libusb-dev

I apologize in advance for taking your time with something that may be very easy, and due to my being new to node.js.

I have a very simple node.js app on Cloud9 and I’m trying to build it using resin. I was able to add the remote but when I push, after the normal git messages I get a strange error: “Starting build for 'claudiuo/cylon Error while processing push: Error: Couldn’t satisfy node version 0.10.22” I am not sure where the 0.10.22 version comes from. On the server I use 0.10.35.

Like I said I am sure this is my fault and has a simple explanation but I can’t figure it out. I’d appreciate any help I can get. I’d love to be able to use resin for this project.

Thank you!


Please ignore the original issue. For some reason, this morning when I tried again, the build process started as expected with Step 0 : FROM resin/rpi-node:0.10.22-onbuild so this is not an issue anymore.

Unfortunately, my project needs libusb to be installed so I need to figure out how to do this, but this is another story.

Following up to my previous comment, it turns out I still need some help. My app is supposed to command a Digispark connected to a USB port of the Pi and for this I need to have libusb-dev installed in the Docker image. I added a preinstall script to the package.json and it seems to work. However, it can’t find libusb-dev, apt-cache only finds libusb-0.1-4. This installs fine but the compilation of the npm packages still fails I think because it really needs a -dev version of the library.

Any idea how I can get past this?

Again, I am grateful for all the help I can get. Thanks in advance!


Sorry for the delay. Have you tried adding an apt-get update line before the apt-get libusb-dev? In our images we tend to strip apt-cache for efficiency so this might be necessary to install the library.

Let me know if this helps!

Best, Lorenzo

I was sure I tried apt-get update but now that you mentioned it, I tried again and it worked.

You are the best! Thank you so much!

1 Like

I am now having that same error reported above:

“Error while processing push: Error: Couldn’t satisfy node version 0.10.22”

I had my simple node.js pushed and built and running on a Pi B+ yesterday. Today I remove one blank line from it’s only source file and push now fails as above.

This is rather odd as I notice it is version 0.10.22 that is used on the Pi anyway.


This is unfortunately a knock-on effect from connectivity issues originating from Docker’s registry, once they have resolved these, it should work correctly.

Best, Lorenzo

OK. Thanks, I’ll look forward to things getting back in shape.

Great, all working again.

1 Like