Pi Day is tomorrow: I could use advise for Pi3 sound config


#1

Pi Day is tomorrow! My work asked people to bring in pies for a social event (cool!). I can’t bake a pie to save my life, so I’m baking a Raspberry Pi LED display that says, “Happy Pi Day!” to place next to the pies. If you could help me figure out a config item, I’ll send a picture! :smiley:

In order to get the display scripts to run, I need to disable the audio card. General instructions are to add a line to a blacklist file and reboot. I’m not sure how this type of edit behaves with docker/balena.

I need to append the line:
blacklist snd_bcm2835
to:
/etc/modprobe.d/raspi-blacklist.conf (which may or may not be created yet)
Then reboot.

What’s the best approach with the docker template file?

Thanks for taking a look in advance!


#4

Hi @Chris and welcome to our forums. I see you are driving an LED display but I can’t understand what is the dependency to the sounds driver. Could you expand?


#11

Hello @agherzan. Sure thing. I chose this node library to manage a small connected LED matrix:

I was able to work through install and dependencies, resulting in a wonderful unicorn ascii art. The error I’m getting is this when starting the node script:

=== snd_bcm2835: found that the Pi sound module is loaded. ===
Don't use the built-in sound of the Pi together with this lib; it is known to be
incompatible and cause trouble and hangs (you can still use external USB sound adapters).

See Troubleshooting section in README how to disable the sound module.
You can also run with --led-no-hardware-pulse to avoid the incompatibility,
but you will have more flicker.
Exiting; fix the above first or use --led-no-hardware-pulse

Since this is somewhere in the Python bits that come in from another module, it’s not simple to simply tack on “–led-no-hardware-pulse”.

Here’s a blog post that further describes the solution I mentioned above:
http://doctormandal.com/raspi-ledmatrix.php


#13

I understand now. We currently set in the config.txt dtparam=audio=on by default. What you can do is set it to off. More info on how to do that you will find here: https://www.balena.io/docs/reference/OS/advanced/#setting-device-tree-overlays-dtoverlay-and-parameters-dtparam.

In short, you will need to access the device configuration menu in dashboard, modify RESIN_HOST_CONFIG_dtparam value and set the audio to off. The device will reboot and you will be able to see that the kernel module is not loaded by default anymore. Just tested this on a balenaFin device.


#18

Nice, and thanks for the test! I look forward to trying this out in the evening (or lunch if I’m quick). I appreciate the tips and will update with results.

:slight_smile: :slight_smile: :slight_smile:


#35

@agherzan your suggestion did the trick!

I didn’t make it for Pi Day due to electric and brain issues, however there’s still time for St. Patrick’s Day!

Thanks for the assist!


#36

hey @Chris, nice photo! :raspberrypi:
Thanks for sharing it with us and for marking @agherzan’s answer as a solution. :+1: