Not able to connect with wifi only

I have downloaded the latest BalenaSound image and copied to sd card.
When I boot the Raspberry Pi 3B+ with ethernet connected, I can see that there are two ipadresses, and, as I would expect, since these are the tow adresses I configured in my DHCP for the ethernet and wifi mac adresses.

It all seems to work well whit ethernet connected.
When I reboot and disconnect the ethernet cable, after some time I see a green light blinking 4 times.
This should point to false wifi settings. But these should be fine, since there is an ip adress for the wifi connection.

I already renamed both radio’s so they have a different name, and set the radio for 2.4 Ghz to channel 1 (all as mentioned in the various forum discussions). All of this doesn’t work

Could you help me with this please?

Hello roy, that does sound strange. Can you try attaching the ethernet cable and then SSHing into the host container to try and run nmcli con show --active, I would also be curious to learn what happens if, after you boot with both connections available, you unplug the ethernet cable, does the device work fine with wifi then?

1 Like

nmcli con show --active gives as reply:

Wired connection 1 b50702d1-ef7d-35ee-962a-9e2ee579f893 ethernet eth0
resin-wifi-01 a58e405d-fdc2-3649-9339-5bbaea740c76 wifi wlan0
supervisor0 e58bcda1-0186-43de-b1d7-a2c55cdfa93c bridge supervisor0

when I remove ethernet cable, the connection is lost

Maybe important to know, I see now the it constantly says “waiting for sound supervisor to start”, while the sound supervisor is running.

Hey there, it looks like you’re correct that the device is able to connect to Wifi while Ethernet is connected as well. You mentioned that you configured specific DHCP addresses for each of the device’s MAC addresses, what would happen if the Wifi MAC address were to change? Does your network hand out DHCP addresses to unrecognized devices?

One thing you can try is grabbing the NetworkManager logs before and after you disconnect/reconnect ethernet. Hopefully something would be indicated here if it was having an issue connecting.

journalctl --no-pager -u NetworkManager

I’ve tried everything I can think off. Disable firewall, disable Pihole, Disable Wifi repeater. Direct access to router, DMZ… all no go.
At last I tried an older version, so i downloaded raspberrypi3-2.56.0+rev2-v11.14.0 and it connects imemdiatly with only WIFI, no ethernet connected.

Seems to be an issue in version raspberrypi3-2.67.3+rev4-v12.3.0?

Hi, can you please also try v2.69 which is available on our staging environment - This one has a newer NetworkManager release. I doubt though we have such a WiFi issue with v2.67 as nobody reported other issues with it, nor we found any with our internal testing. It is not impossible though, as it could be a problem that only occurs with your router setup.

V2.69 connects to wifi perfectly

Thanks for reaching back to us. Glad we could resolve this for you. balenaOS v2.69 will be available in soon as well.