Balenasound wifi not working/not connecting

i installed balena sound and with ethernet its working perfectly fine but if i disconnect the ethernet its not working even after a reboot. when i created the device i took the option wifi+Ethernet and entered my credentials


Did I understand the problem correctly?
If you power on the device with Ethernet connected, it will connect to the dashboard and show up as online. If you now disconnect Ethernet and reboot it, it should connect to WiFi and also show up online, but it does not. And you selected WiFi + Ethernet when downloading the device image and filled in the form correctly for the WiFi credentials.

If you selected WiFi + Ethernet it should connect to both also when connected to Ethernet. You could connect it to Ethernet and log into the device via the dashboard. There you can run nmcli c to see the status of the network connections. To check in more depth each connection you can use nmcli c show <connection uuid>.

Maybe you can find the problem with the WiFi connection this way. If not let us know and we will be happy to help to find the root of the problem. It would also be interesting what device you use and what OS version.

Best Regards,

ethernet is connected but at wifi it shows:

wlan0: disconnected
1 connection available
wifi (brcmfmac), D2:73:E1:0B:29:D7, hw, mtu 1500

@ItzChriZz what device are you using? If you’re using a Pi Zero W, be aware that it will not connect to 5GHz wifi networks.

In addition to nmcli you can also use the terminal interface when connected via ethernet to check the credentials you provided for typos by looking at the files in /mnt/boot/system-connections; simply run cat <filename> to display the contents. If you do find something incorrect here you can edit the files by plugging the SD card back into another computer, or from the host OS terminal using vi.

I hope this helps!

everything i see there is correct

@ItzChriZz please can you clarify what hardware you are using and what other troubleshooting steps you’ve tried?

i am using a rpi3b+ and i tried everything you told me

Could you enable support access for your device and share the dashboard URL here? We’ll then be able to log in and take a look.

yes of course heres ther url:

@ItzChriZz I’ve performed a WiFi scan from your device and can see it’s not in range of the network you’ve set up. Your configuration is saying connect to the UBNT network, but the only similar visible one is UBNT_5G.

i’ve configured it to use the 2.4g network because it has more range and i’m sitting nearby my accesspoint from Ubiquiti Networks you could try to connect to UBNT_5G the password is: 98132379

In that case, you need to edit the file in /mnt/boot/system-connections to include these new credentials and then reboot the device. It will then try to connect to the UBNT_5G network.