Node-red in resin (on RPi)


I have made many failed attempts to have node-red running in my resin application.

I would like to have my nodes & flows in the /app directory, but node-red fails to build at /app

(I tried the instructions from

I managed to do a global installation of node-red in (npm install -g node-red) but when I run it, it fails to load my settings.js located at /app … (I would like to keep my app files at /app and not at /.node-red).

Since node-red is such a great tool for “wiring” the Internet of Things it would be great if resin could provide a node-red “ready” image :slight_smile: … or give us some hints to work properly on node.js applications with node-red on

Any help much appreciated.


I had a problem with my settings.js file and that’s why it failed to be loaded by node-red.

No I have it working with a global node-red installation and then setting userDir to /app


Hey there, good to hear you got it working! Would you be willing to write up a guide to help others in the future?


Sure! I will deal with several details in my sample project and then will share a guide with the steps.


Hi, I’d be interested in this Node-RED installation. Please, could you share some basic steps to make it working?

Thanks in advance!


Please check this repository with a basic version of node-red that worked for me with

There is an explanation in the Readme file

Best wishes!!