No sound after deploy

Hello
I’ve deployed successfully Balenasound on Orange PI Zero LTS
The thing is audio service doesn’t detect any sound card
09.05.22 17:00:51 (+0200) audio — Audio —
09.05.22 17:00:51 (+0200) audio Starting audio service with settings:
09.05.22 17:00:53 (+0200) audio - pulseaudio 15.0
09.05.22 17:00:53 (+0200) audio - Pulse log level: NOTICE
09.05.22 17:00:53 (+0200) audio - Default output: AUTO
09.05.22 17:00:53 (+0200) audio - Default volume: 75%
09.05.22 17:00:53 (+0200) audio
09.05.22 17:00:53 (+0200) audio Detected audio cards:
09.05.22 17:00:53 (+0200) audio cat: can’t open ‘/proc/asound/cards’: No such file or directory
09.05.22 17:00:53 (+0200) audio
09.05.22 17:00:53 (+0200) audio
09.05.22 17:01:03 (+0200) audio cat: can’t open ‘/proc/asound/cards’: No such file or directory
09.05.22 17:01:03 (+0200) audio cat: can’t open ‘/proc/asound/cards’: No such file or directory
09.05.22 17:01:03 (+0200) audio cat: can’t open ‘/proc/asound/cards’: No such file or directory
09.05.22 17:01:03 (+0200) audio cat: can’t open ‘/proc/asound/cards’: No such file or directory
09.05.22 17:01:03 (+0200) audio cat: can’t open ‘/proc/asound/cards’: No such file or directory

Any solution ? It’s working fine on Raspberry PI 4, but since the cost of this one is over expensive, Orange Zero is a great alternative

Thanks for your help

1 Like

Hi,

I found a previous forum post where you say that you solved this using Volumio: No sound on Orange Pi Zero - #2 by beber666

Could you expand on how you used Volumio, and why that didn’t work here?

Thanks,
Christina

1 Like

Hello

Thank you for your reply :slight_smile:

That’s sad to say, buy Volumio works out of the box on my Orange PI Zero 1

With Balena Sound, it’s almost perfect, except I don’t have sound…

Do you have an idea to fix this issue ? Because I really prefer to use Balena Sound

1 Like

@beber666,

Can you share which version of balenaOS you’re testing in both instances? I’m wondering if there are any updates to meta-balena that you might be seeing in Raspberry Pi images (which we update frequently) and the Orange Pi Zero images (which we update less frequently)?

Our plan is to automate testing over time so that we are better able to keep up with updates across our device-types, but today it is a manual process, so we update mostly upon request for the less common device-types, of which the Orange Pi is one.

Anyway, let me know about your OS versions and then we can look into updates between them in meta-balena to see if there are updates that might have resolved audio issues for RPi that you’re not seeing in Orange Pi. Thanks!

1 Like

Thank you for your support.

Here is the informations about the version I used [balenaOS 2.53.9+rev1]

Diagnostic file if needed PrivateBin (you need to wait a bit to let it displaying)

1 Like

Hi, any news ? Thank you

1 Like

Hi, sorry! A colleague has sent a reply though our internal support system, but for some reason it didn’t get replicated to the forum as it should. I am copying his response below:

Hi, the default sound output for Orange Pi is HDMI (How to switch the default audio device). Do you have a way of testing whether sound would come out of it?

1 Like

Thank yo for your reply

There is no HDMI output on the Orange PI Zero :slight_smile:
With the hat, it bring the Jack Output, and in all cases we’ve got also the USB output

I guess that’s the issue !

1 Like

Hello Some news ?

1 Like

up

1 Like

Hi

From the diagnostic logs it looks like you’re running a GeneralPlus USB Audio Device like this one GeneralPlus | USB Audio Cards with a Raspberry Pi | Adafruit Learning System.

I don’t see that as directly supported, but you could try using the USB device output. Have you checked Audio interfaces - Home ? You may need to set up the device ( see Customization - Home and audio/README.md at master · balenablocks/audio · GitHub )

Ramiro

1 Like

Hello

I confirm that the USB Audio is not working on this device.
But the exact same device works with raspberry PI with BalenaSound
I’m pretty sure it’s not the issue

1 Like

I am having this same issue. Please is there a way to fix it??? I just dropped like $60 on 2 orange pi zeros and don’t want to have 2 paper weights…

On my side for the moment I’m using Volumio , there is community edition that is working great with Orange Pi Zero
I don’t understand why Balena doens’t support it, since Raspberry it simply over expensive for the moment

Hello,

From what you describe it looks like this might be a balenaos or balenasound issue.

We don’t have the bandwidth to investigate further at the moment, but this is a open-source project and we welcome contributions :wink:

You should check the logs of the host kernel ( dmesg ) to see if there’s anything odd happening when plugging the usb sound card.

Hello

You mean this one ?
https://websolutis.com/bin/?8c6a0e410f551382#teZmre9xU++0XBiseUa7BMdkciZ6h+nW3D/dWZsu/SQ=

Hi

From the previous messages, it looks like the device is listed as a USB device but not as a sound card (snd-usb-audio).

In order to pinpoint the difference, it would be useful if you could plug the device on the raspberry pi ( where you mention it is recognized as a sound card ) and share the diagnostics file. That way we can compare both devices.

Thanks, Ramiro

Hi, I’m having the same issue. In my case I bought 3 Orange Pi Zero’s to create a multiroom setup in my home

I got a volumio image that I’ve configured if you need multi room, I’m using it, waiting for balena support it

Thank you for your reply, I’ve tried it, but since the Volumio build that I’ve found it’s for Orange Pi Pc, it doesn’t have Wifi, and this is not useful for me.
Best regards