No services displayed in the dashboard

I’ve flashed the balenaSound image to my Rpi3 and it is displayed in the dashboard but without the services and i cant connect to it via BT or AirPlay.

My dashboard looks like this but on any screen i have seen the services is displayed here. Any ideas what i can do ?

Hello @Joma welcome to our forums!

Did you use the “Deploy with balena” in our GH repo or blog post? Can you retry to deploy? You can use the same application (balena-sound).

You should se a ‘building release xxx’ message after a few minutes.



@ntzovanis I’ve decided to create a new application as i hoped i did someting wrong with creating the other one. It showed me a ‘building release xxx’ i the dashboard and after that finished i created a new device like on the blog(i used the deploy with dalena). Flashed the image and pluged it into my Rpi 3. After a short period of time the device showed up in the dashboard, it didnt show any services again and the logs stopped with ‘Applied configuration change {“SUPERVISOR_DELTA”:“1”}’. After that nothing else happends.Thank you for your help.

Regards, Joma.

Hi there, do you have at least one release deployed to the application, where your device is provisioned? You can check this on the dashboard, in the application/releases context.

@ab77 It shows a Release No commit on my application dashboard.

Hey @Joma this is a strange one. I’ve just deployed a new balenaSound Pi 3 (not 64-bit) application in my dashboard and the application has built successfully and so my releases page looks like the below:

In the case yours does not look like this, could you please share a screenshot? I am not aware of any place where it says No commit on the dashboard. If you’re seeing No release that means that for some reason the build has failed, and you can see why by going to the releases page within your application (as shown in my screenshot above). If you are seeing a failed build, you can try again by clicking the Deploy with balena button and selecting an existing application using the link at the top of the modal that pops up in the dashboard instead of creating a new one. You can also click into the failed build and check the logs on the right hand side to see if it offers any more information that helps figure out what went wrong.

The no release is actually correct, the deployment fails with this error message.

Hey @Joma it looks like the previous release failed to build successfully. The error you get - 404 - no such image - is due to an issue on our end with the builders, but most of the times it can be simply solved by re-triggering the build. You can do that by clicking the Deploy with balena button and selecting the application you created using the link at the top of the modal that pops up in the dashboard instead of creating a new one. Apologies for this, we are currently working on fixing this problem with the builders.

I restarted the build and now it workes and all services are shown in the device dashboard.
Thanks to everyone for the quick help.
Im going to enjoy some Musik now.
Regards, Joma.

Glad to hear that worked for you @Joma, enjoy your new balenaSound device :slight_smile:

1 Like